Bug 854293 - [RFE] As the katello admin I would like katello to do a ldap query to validate the user being created exists in ldap before returning success.
[RFE] As the katello admin I would like katello to do a ldap query to validat...
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
high Severity high
: rc
: 1.3
Assigned To: Jordan OMara
SAM QE List
: FutureFeature, Triaged
: 854292 871283 (view as bug list)
Depends On: 854292 994782
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2012-09-04 11:00 EDT by Eric Sammons
Modified: 2014-11-09 17:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 854292
Environment:
Last Closed: 2013-10-01 06:48:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Sammons 2012-09-04 11:00:43 EDT
+++ This bug was initially created as a clone of Bug #854292 +++

Description of problem:
As a katello admin, when creating a user in my katello deployment (configured for ldap) I would like katello to do a form validation to ensure the user being created exists in ldap before returning "User created successfully".  If the user does not exist the appropriate error should be returned; "User must exist in ldap before defining here."
Comment 1 Jordan OMara 2012-11-05 15:41:37 EST
*** Bug 871283 has been marked as a duplicate of this bug. ***
Comment 2 Bryan Kearney 2013-07-15 15:43:02 EDT
This has been delivered.
Comment 3 sthirugn@redhat.com 2013-08-13 13:47:42 EDT
Verified for Active Directory and free ipa configurations. This bug will be marked verified after verification in posix configuration too (https://bugzilla.redhat.com/show_bug.cgi?id=994782)
Comment 4 sthirugn@redhat.com 2013-08-16 16:17:50 EDT
*** Bug 854292 has been marked as a duplicate of this bug. ***
Comment 5 sthirugn@redhat.com 2013-08-16 16:25:57 EDT
VERIFIED for Active Directory and free_ipa.  Posix issue will be tracked under https://bugzilla.redhat.com/show_bug.cgi?id=994782

Version tested:
* candlepin-0.8.19-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.19-1.el6sam.noarch
* candlepin-tomcat6-0.8.19-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-5.el6sat.noarch
* katello-cli-common-1.4.3-5.el6sat.noarch
* katello-common-1.4.3-6.el6sam_splice.noarch
* katello-configure-1.4.4-2.el6sat.noarch
* katello-glue-candlepin-1.4.3-6.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-6.el6sam_splice.noarch
* katello-headpin-1.4.3-6.el6sam_splice.noarch
* katello-headpin-all-1.4.3-6.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch
Comment 7 errata-xmlrpc 2013-10-01 06:48:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.