Bug 854304 - reset PMBA and PMREGMISC PIIX4 registers
reset PMBA and PMREGMISC PIIX4 registers
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Laszlo Ersek
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-04 11:16 EDT by Laszlo Ersek
Modified: 2013-02-21 02:39 EST (History)
9 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.311.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 02:39:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backport (1.27 KB, patch)
2012-09-04 11:20 EDT, Laszlo Ersek
no flags Details | Diff

  None (edit)
Description Laszlo Ersek 2012-09-04 11:16:22 EDT
backport the following commit from upstream:

commit 4d09d37c6aa9a02b44b1fdb6268820fab92499bd
Author: Gleb Natapov <gleb@redhat.com>
Date:   Tue Aug 7 15:52:03 2012 +0300

    reset PMBA and PMREGMISC PIIX4 registers.
    
    The bug causes Windows + OVMF hang after reboot since OVMF
    checks PMREGMISC to see if IO space is enabled and skip
    configuration if it is.
    
    Reviewed-by: Laszlo Ersek <lersek@redhat.com>
    Signed-off-by: Gleb Natapov <gleb@redhat.com>
    Signed-off-by: Anthony Liguori <aliguori@us.ibm.com>

I've just posted a series for OvmfPkg that changes the platform pre-EFI initialization such that it depends on (PMREGMISC & PMIOSE) == 0 rather than on !Xen. I'll need the designated commit in RHEL-6 so that I can use official Brew builds to test OVMF + Windows.

http://sourceforge.net/mailarchive/forum.php?thread_name=1346770816-14130-1-git-send-email-lersek%40redhat.com&forum_name=edk2-devel
http://sourceforge.net/mailarchive/forum.php?thread_name=1346770816-14130-2-git-send-email-lersek%40redhat.com&forum_name=edk2-devel
http://sourceforge.net/mailarchive/forum.php?thread_name=1346770816-14130-3-git-send-email-lersek%40redhat.com&forum_name=edk2-devel
http://sourceforge.net/mailarchive/forum.php?thread_name=1346770816-14130-4-git-send-email-lersek%40redhat.com&forum_name=edk2-devel
http://sourceforge.net/mailarchive/forum.php?thread_name=1346770816-14130-5-git-send-email-lersek%40redhat.com&forum_name=edk2-devel
http://sourceforge.net/mailarchive/forum.php?thread_name=1346770816-14130-6-git-send-email-lersek%40redhat.com&forum_name=edk2-devel
http://sourceforge.net/mailarchive/forum.php?thread_name=1346770816-14130-7-git-send-email-lersek%40redhat.com&forum_name=edk2-devel
Comment 1 Laszlo Ersek 2012-09-04 11:20:08 EDT
Created attachment 609726 [details]
backport
Comment 6 FuXiangChun 2012-10-10 04:30:53 EDT
Hi Laszlo
   Should i how to reproduce this issue as kvm QE?
Comment 7 Laszlo Ersek 2012-10-10 04:43:50 EDT
I think sanity checking suffices.
Comment 9 FuXiangChun 2013-01-03 22:12:06 EST
verify this issue with qemu-kvm-0.12.1.2-2.348.el6.x86_64 and kernel 2.6.32-348.el6.x86_64

Do sanity testing with two scenarios

1. Install guest with Windows8-ConsumerPreview-64bit-English.iso
CD-ROM: IDE
disk: IDE
NIC model: e1000
RAM: 4G
VCPUs: 4
disk size: 30G
connection: vnc

2.Install guest with Windows8-ConsumerPreview-64bit-English.iso
CD-ROM: IDE
disk: virtio-blk-pci
NIC model: virtio-net-pci
RAM: 2G
VCPUs: 4
disk size: 30G
connection: spice

result:
win8 can be installed successfully and works well. 

Laszlo,
according to testing result. can verify this bug?
Comment 10 Laszlo Ersek 2013-01-04 02:57:59 EST
The important thing to test is resetting the VM. (That is, don't create a new VM, instead, reset the VM from the inside.)

IIRC windows8 installation involves several resets (at least three). I think you can set this to VERIFIED. Thanks!
Comment 11 FuXiangChun 2013-01-05 01:32:32 EST
resetting(my understanding is that reboot VM) many times VM from the inside, VM work normally.
Comment 13 errata-xmlrpc 2013-02-21 02:39:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0527.html

Note You need to log in before you can comment on or make changes to this bug.