Bug 854346 - gdata-java: Please remove bundled jars before building
gdata-java: Please remove bundled jars before building
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gdata-java (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-04 13:13 EDT by Mikolaj Izdebski
Modified: 2012-10-15 01:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 01:33:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch fixing the problem (1.29 KB, patch)
2012-09-04 13:19 EDT, Mikolaj Izdebski
no flags Details | Diff

  None (edit)
Description Mikolaj Izdebski 2012-09-04 13:13:21 EDT
gdata-java sources contain bundled jar files.
According to packaging guidelines these jars should be removed prior to building. Please do so.

List of jar files:
./gdata/java/deps/jsr305.jar
./gdata/java/deps/google-collect-1.0-rc1.jar

Note: there is already a "rm -rf" in %prep. Consider fixing it to remove all jars.
Comment 1 Mikolaj Izdebski 2012-09-04 13:19:32 EDT
Created attachment 609748 [details]
Patch fixing the problem

F19 scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4453107
Comment 2 Mikolaj Izdebski 2012-09-04 13:34:02 EDT
The scratch build failed meaning that the package was probably using the bundled jars (google collections). However my bug report still remains valid.

I would appreciate if you investigated the situation and removed bundled code. 

As an additional node, jsr305.jar contains *code* licensed under CC-BY-SA license, which is approved by Fedora Legal, but only for content, not for code. However I suspect that the affected files are too simple to be copyrightable in the first place.
Comment 3 Sandro Mathys 2012-09-04 16:16:50 EDT
Hi Mikolaj,

Thanks for the report (that really wasn't the intent) and the proposed patch. Unfortunately I lack the time to investigate major issues in this package (you also have seen the other bug open against that component - another issue that keeps me from rebuilding).

If you're interested, I'd be happy to transfer ownership to you. Otherwise I'll probably have to orphan this package (and because of what you said above, maybe unpush it alltogether).

Let me know what you think.
Comment 4 Mikolaj Izdebski 2012-09-05 04:15:19 EDT
Exactly for situations like that Fedora has comaintainers - other people that can take care of the package when the primary maintainer is unable to. I have asked for commit rights, if you approve me I can help by becoming a comaintainer.

I can also become comaintainer of commons-compress as I already own most of apache-commons packages and xz-java (another Java compression library, which commons-compress depneds on). I have also asked for commit rights for it.
Comment 5 Mikolaj Izdebski 2012-09-05 04:17:44 EDT
I can see you already approved me, before I added comment 4 :)
Comment 6 Sandro Mathys 2012-09-05 04:19:59 EDT
Sure, I know about co-maintainers. Point is those two packages used to be important for something I did (or actually tried to do) a few years ago - but nowadays I have no use for them personally. Therefore I'd happily consider releasing ownership if someone wants to step up and take over the responsibility.

That said, I granted all your requests on both packages.
Comment 7 Mikolaj Izdebski 2012-09-05 04:26:47 EDT
If you really have no interest in these packages any longer then you can orphan them. If you do so I will adopt them.
Comment 8 Mikolaj Izdebski 2012-10-15 01:33:32 EDT
Package gdata-java in Fedora devel has been retired.

Note You need to log in before you can comment on or make changes to this bug.