Bug 854369 - PRD33 - [RHEVM-SHELL] : Add option to retrieve system summary
PRD33 - [RHEVM-SHELL] : Add option to retrieve system summary
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-cli (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Juan Hernández
Ilia Meerovich
infra
: Improvement
Depends On:
Blocks: 976618
  Show dependency treegraph
 
Reported: 2012-09-04 15:03 EDT by Oded Ramraz
Modified: 2016-09-12 05:01 EDT (History)
10 users (show)

See Also:
Fixed In Version: is3
Doc Type: Enhancement
Doc Text:
The "summary" option can now be used to retrieve a system summary reporting the status of hosts, storage, users, and virtual machines.
Story Points: ---
Clone Of:
: 976618 (view as bug list)
Environment:
Last Closed: 2014-01-21 10:53:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dyasny: Triaged+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 12964 None None None Never

  None (edit)
Description Oded Ramraz 2012-09-04 15:03:41 EDT
Description of problem:

It would be nice to have the option to retrieve system summary using engine-cli. 
We have this option in Rest API as well. 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

<summary>
<vms><total>5</total><active>3</active></vms>
<hosts><total>2</total><active>2</active></hosts><
users><total>2</total><active>1</active></users>
<storage_domains><total>2</total><active>2</active></storage_domains>
</summary>
Comment 1 Michael Pasternak 2013-03-12 06:35:15 EDT
[oVirt shell (connected)]# summary

hosts-active          : 0
hosts-total           : 4
storage_domains-active: 3
storage_domains-total : 4
users-active          : 1
users-total           : 3
vms-active            : 0
vms-total             : 7
Comment 2 Ilia Meerovich 2013-07-03 08:02:44 EDT
Build: IS4
[imeerovi@imeerovi storage_api]$ /usr/bin/rhevm-shell -c --url=https://ilia-rhevm.qa.lab.tlv.redhat.com:443/api/ -u admin@internal -I

 ==========================================
 >>> connected to RHEVM manager 3.3.0.0 <<<
 ==========================================


        
 ++++++++++++++++++++++++++++++++++++++++++
 
           Welcome to RHEVM shell
 
 ++++++++++++++++++++++++++++++++++++++++++
        
    
[RHEVM shell (connected)]# summary

hosts-active          : 0
hosts-total           : 0
storage_domains-active: 0
storage_domains-total : 1
users-active          : 1
users-total           : 2
vms-active            : 0
vms-total             : 1

[RHEVM shell (connected)]#
Comment 4 errata-xmlrpc 2014-01-21 10:53:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0076.html
Comment 5 Jakub Hrozek 2016-09-11 16:21:55 EDT
Upstream ticket:
https://fedorahosted.org/sssd/ticket/2711
Comment 6 Juan Hernández 2016-09-12 04:40:28 EDT
Jakub, you may have used an incorrect bug number.
Comment 7 Jakub Hrozek 2016-09-12 05:01:35 EDT
(In reply to Juan Hernández from comment #6)
> Jakub, you may have used an incorrect bug number.

Of course I did, sorry about that

Note You need to log in before you can comment on or make changes to this bug.