Bug 854388 - Contract(s) Listing Update in My Installed Products Details Pane
Contract(s) Listing Update in My Installed Products Details Pane
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Shwetha Kallesh
Entitlement Bugs
:
Depends On:
Blocks: 771481 840993
  Show dependency treegraph
 
Reported: 2012-09-04 17:08 EDT by Matt Reid
Modified: 2013-02-21 03:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:55:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Covered by contract (118.84 KB, image/png)
2012-12-17 01:32 EST, Shwetha Kallesh
no flags Details

  None (edit)
Description Matt Reid 2012-09-04 17:08:06 EDT
Description of problem:
It would be nice if we got rid of our generic contract(s) string, and had unique strings for single contracts and multiple contracts. This is displayed in the My Installed Products tab, down in the Product's Subscription Details pane, in Certificate Status.

Current string:
"Covered by contract(s) [Contract Number] through [End Date]"

Desired string:
"Covered by contract [Contract Number] through [End Date]"
"Covered by contracts [Contract Number] and [Contract Number] through [earliest End Date]"
"Covered by contracts [Contract Number], [Contract Number] and [Contract Number] through [earliest End Date]"

Is it trivial to have the last contract (as long as there are 2+) be prefixed with an 'and' and have any subsequent ones use a comma?
Comment 1 Adrian Likins 2012-11-16 16:01:11 EST
commit 23355b6c4e59f7000abace908b5225be99576c79
Author: Adrian Likins <alikins@redhat.com>
Date:   Fri Nov 16 14:38:39 2012 -0500

    854388: use ngettext to specify contract/contracts
Comment 2 Adrian Likins 2012-11-19 10:29:28 EST
commit e995613e4057ff8b39dbd48d7979dc26ec18a02c
Author: William Poteat <wpoteat@redhat.com>
Date:   Sun Nov 18 19:17:37 2012 -0500

    854388: Make comma separated list include 'and'
    
    Replace the last comma with and to make proper grammar
Comment 4 Shwetha Kallesh 2012-12-17 01:32:10 EST
Created attachment 664697 [details]
Covered by contract

Moving to verified!!

[root@rhel-64-server ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.7.21-1
subscription-manager: 1.1.15-1.el6
python-rhsm: 1.1.7-1.el6
Comment 6 errata-xmlrpc 2013-02-21 03:55:59 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.