Bug 854391 - ovirt-engine-cli: valid UUID's are treated as syntax error
ovirt-engine-cli: valid UUID's are treated as syntax error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-cli (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Michael Pasternak
Oded Ramraz
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-04 17:21 EDT by Oded Ramraz
Modified: 2016-02-10 14:32 EST (History)
7 users (show)

See Also:
Fixed In Version: si18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 14:56:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oded Ramraz 2012-09-04 17:21:15 EDT
Description of problem:

RHEVM shell accept UUID's such as def00006-0000-0000-0000-def000000006 but doesn't accept UUID's which starts with a digit : e.g 00000000-0000-0000-0001-000000000001
See example in Additional Information . 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

[RHEVM shell (connected)]# list roles | grep 00
id         : 00000000-0000-0000-0001-000000000001
id         : 00000000-0000-0000-0001-000000000002
id         : def00006-0000-0000-0000-def000000006
id         : def00008-0000-0000-0000-def000000008

.....


[RHEVM shell (connected)]# list permits --role-identifier def00006-0000-0000-0000-def000000006

id         : 1
name       : create_vm

id         : 2
name       : delete_vm

id         : 3
name       : edit_vm_properties

id         : 4
name       : vm_basic_operations

....


[RHEVM shell (connected)]# list permits --role-identifier 00000000-0000-0000-0001-000000000001
error: syntax error
Comment 1 Michael Pasternak 2012-09-05 04:22:17 EDT
the problem is that you pass UUID where string is expected
Comment 2 Oded Ramraz 2012-09-05 04:27:03 EDT
(In reply to comment #1)
> the problem is that you pass UUID where string is expected

Why this operation succeed?

[RHEVM shell (connected)]# list permits --role-identifier def00006-0000-0000-0000-def000000006

id         : 1
name       : create_vm

id         : 2
name       : delete_vm

id         : 3
name       : edit_vm_properties

id         : 4
name       : vm_basic_operations
Comment 3 Michael Pasternak 2012-09-05 06:28:02 EDT
cause it starts with the letter and got boxed to string
Comment 5 Oded Ramraz 2012-09-13 05:38:56 EDT
Verified si18:

[RHEVM shell (connected)]# show vm 2041e0c8-b2a1-4dd5-8f94-e4b04215a622

id                        : 2041e0c8-b2a1-4dd5-8f94-e4b04215a622
name                      : fromtemplate
cluster-id                : 99408929-82cf-4dc7-a532-9d998063fa95
cpu-topology-cores        : 1
cpu-topology-sockets      : 1
creation_time             : 2012-09-12T12:25:25.464+03:00
display-address           : 10.35.103.11
display-allow_reconnect   : False
display-monitors          : 1
display-port              : 5900
display-secure_port       : 5901
display-type              : spice
high_availability-enabled : False
high_availability-priority: 1
host-id                   : 516eac3c-fca4-11e1-a24d-8b025e17fa1b
memory                    : 2147483648
memory_policy-ballooning  : True
memory_policy-guaranteed  : 2147483648
origin                    : rhev
os-boot-dev               : hd
os-type                   : rhel_6x64
placement_policy-affinity : migratable
quota-id                  : 00000000-0000-0000-0000-000000000000
start_time                : 2012-09-12T12:25:42.957+03:00
stateless                 : False
status-state              : up
template-id               : a734f08c-f2fa-4347-8c5b-a0032eb653d5
type                      : desktop
usb-enabled               : False

Note You need to log in before you can comment on or make changes to this bug.