Bug 854394 - qpid-cpp-server 0.16-5 update removes service scripts
qpid-cpp-server 0.16-5 update removes service scripts
Status: CLOSED DUPLICATE of bug 854263
Product: Fedora
Classification: Fedora
Component: qpid-cpp (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Darryl L. Pierce
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-04 17:26 EDT by Steven Hardy
Modified: 2015-06-21 20:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-11 13:07:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Hardy 2012-09-04 17:26:24 EDT
Description of problem:

Updating from earlier versions of qpid-cpp-server to 0.16-5 or newer removes /etc/rc.d/init.d/qpidd, which has been repackaged into the qpid-cpp-server-daemon

This change may be OK for rawhide or pre-release Fedora versions, but it has been applied to current stable releases (both F16 and F17 are affected)

This is contravening several guidelines in the Fedora updates policy:

http://fedoraproject.org/wiki/Updates_Policy

Specifically:
-  Updates should aim to fix bugs, and not introduce features, particularly when those features would materially affect the user or developer experience.
- Avoid changing the user experience if at all possible. 

I think a dependency should be added to qpid-cpp-server so it will automatically install the required qpid-cpp-server-daemon package is installed, keeping the update transparent for existing users.  

The current approach breaks the package for all existing users after a "yum update", in a not-necessarily-obvious way.

Version-Release number of selected component (if applicable):

qpid-cpp-server-0.16-5 onwards

How reproducible:

Always

Steps to Reproduce:
1. Do a "yum update" from qpid-cpp-server-0.16-4 or earlier
2. Restart qpidd or reboot
3. Observe the following error
  
Actual results:

Error message, service is not started, the init.d/qpidd script is deleted.

```
Failed to issue method call: Unit qpidd.service failed to load: No such file or directory. See system logs and 'systemctl status qpidd.service' for details.
```

Expected results:

Should not break on update, the init.d/qpidd script should not be deleted on "yum update", this change should be made transparent to end-users and downstream projects for stable Fedora versions.

Additional info:
Comment 1 Darryl L. Pierce 2012-09-11 13:07:52 EDT

*** This bug has been marked as a duplicate of bug 854263 ***

Note You need to log in before you can comment on or make changes to this bug.