Bug 854403 - Using the sessions command when using tcm_fc results in error messages
Using the sessions command when using tcm_fc results in error messages
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: targetcli (Show other bugs)
17
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Andy Grover
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-04 18:44 EDT by Mark Rustad
Modified: 2012-11-14 21:46 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-23 23:21:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Rustad 2012-09-04 18:44:39 EDT
Description of problem:
Using the sessions command when using tcm_fc results in error messages

Version-Release number of selected component (if applicable):
targetcli-2.0rc1.fb12-1.fc17
python-rtslib-2.1.fb14-1.fc17

How reproducible:
Set up an FCoE target with luns assigned to an FCoE initiator. From within targetcli, type sessions list

Steps to Reproduce:
1. Set up an FCoE target with luns assigned to an FCoE initiator
2. Discover the luns from the initiator
3. Enter "sessions list" command into targetcli
  
Actual results:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/configshell/shell.py", line 990, in run_interactive
    self._cli_loop()
  File "/usr/lib/python2.7/site-packages/configshell/shell.py", line 813, in _cli_loop
    self.run_cmdline(cmdline)
  File "/usr/lib/python2.7/site-packages/configshell/shell.py", line 934, in run_cmdline
    self._execute_command(path, command, pparams, kparams)
  File "/usr/lib/python2.7/site-packages/configshell/shell.py", line 909, in _execute_command
    result = target.execute_command(command, pparams, kparams)
  File "/usr/lib/python2.7/site-packages/targetcli/ui_node.py", line 84, in execute_command
    pparams, kparams)
  File "/usr/lib/python2.7/site-packages/configshell/node.py", line 1405, in execute_command
    result = method(*pparams, **kparams)
  File "/usr/lib/python2.7/site-packages/targetcli/ui_root.py", line 202, in ui_command_sessions
    printed_sessions = list(root.sessions)
  File "/usr/lib/python2.7/site-packages/rtslib/root.py", line 134, in _list_sessions
    if na.session:
  File "/usr/lib/python2.7/site-packages/rtslib/target.py", line 883, in _get_session
    lines = fread("%s/info" % self.path).splitlines()
  File "/usr/lib/python2.7/site-packages/rtslib/utils.py", line 102, in fread
    file_fd = open(path, 'r')
IOError: [Errno 2] No such file or directory: '/sys/kernel/config/target/fc/20:00:00:1b:21:87:a6:fb/tpgt_1/acls/20:00:00:1b:21:87:ac:7b/info'


Expected results:
Well, certainly not errors. It would be nice to get some status on the initiators, but I recognize that FCoE is different from iSCSI in terms of sessions. At a minimum, there should not be these errors.

Additional info:
Comment 1 Andy Grover 2012-09-06 18:25:10 EDT
fixed, will be in fb22.

If fcoe fabric wants to report session info, it probably should support an "info" configfs file similar to iscsi's.
Comment 2 Fedora Update System 2012-09-06 18:56:36 EDT
python-rtslib-2.1.fb22-1.fc17,targetcli-2.0rc1.fb16-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-rtslib-2.1.fb22-1.fc17,targetcli-2.0rc1.fb16-1.fc17
Comment 3 Fedora Update System 2012-09-06 18:56:49 EDT
python-rtslib-2.1.fb22-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-rtslib-2.1.fb22-1.fc18
Comment 4 Fedora Update System 2012-09-07 07:37:54 EDT
Package python-rtslib-2.1.fb22-1.fc17, targetcli-2.0rc1.fb16-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-rtslib-2.1.fb22-1.fc17 targetcli-2.0rc1.fb16-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13497/python-rtslib-2.1.fb22-1.fc17,targetcli-2.0rc1.fb16-1.fc17
then log in and leave karma (feedback).
Comment 5 Mark Rustad 2012-09-20 17:35:58 EDT
I finally got around to trying this update, but neither package seems to be found in updates-testing.
Comment 6 Fedora Update System 2012-09-23 23:21:34 EDT
python-rtslib-2.1.fb22-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2012-11-14 21:46:57 EST
targetcli-2.0rc1.fb16-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.