Bug 854423 - uncaught exception: keys not found, also Runtime Error.
uncaught exception: keys not found, also Runtime Error.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openerp (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Alec Leamas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-04 20:42 EDT by Patrick Dubois
Modified: 2012-09-26 05:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-26 04:57:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch against git master HEAD to allow the package to be built and installed on EL 6 w/ EPEL (2.39 KB, patch)
2012-09-14 08:54 EDT, Jeroen van Meeuwen
no flags Details | Diff

  None (edit)
Description Patrick Dubois 2012-09-04 20:42:33 EDT
Description of problem:
A default installation of OpenERP results in graphs not displaying at all and runtime errors.

Version-Release number of selected component (if applicable):
6.1

How reproducible:
Always

Steps to Reproduce:
1. Install postgres and openerp.
2. Configure Database user and rights, configure openerp.conf.
3. Start openerp, point your browser to port 8069, create a database.
4. Install CRM module (first module, top left) 
5. error box appears with runtime error.  
6. error box appears with 'key graph not found' error.
  
Actual results:
Runtime and key-not-found errors.  No graphs or calanders.

Expected results:
Everything should function without error.

Additional info:

Errors are : 
--
Error: QWeb2 - template['ListView.rows']: Runtime Error: Error: QWeb2 - template['ListView.row']: Runtime Error: Error: QWeb2: Template 'ListView.ProgressBar' not found

http://devel.home.pdubois.com:8069/web/webclient/js:18953
--

and ...

--
uncaught exception: The key graph was not found
:0
--
Comment 1 Patrick Dubois 2012-09-08 10:07:37 EDT
Using the existing Fedora17 packaging I rebased on the current nighly build and discovered the Qweb2 Runtime error went away.  

The uncaught exception remains however, and appears to affect any and all graphs that may be displayed in the web interface.  

After experimenting with the GTK client it appears the openerp server is OK, the problem most likely resides in the web interface.
Comment 2 Alec Leamas 2012-09-10 07:26:44 EDT
Hi Patrick!

Thanks for your work, sorry I havn't dived into this until now.

Basically, the web client is non-functional - I have not been able to package several packages due to bundling and licensing concerns. One of the removed packages is openerp/addons/web_graph, and without too much investigation this is likely to cause these failures(?) If you are motivated to make some tries, you could see what happens if commenting this part of the spec:

# Wiki contains other licenses and bundled modules, skipped
# for now. Web modules are anyway better packaged in the web-client.
rm -rf openerp/addons/wiki/web openerp/addons/wiki/static\
       openerp/addons/web_graph openerp/addons/web_calendar


Basically, removing is what's possibly at this point IMHO, but its really bad it it isn't mentioned in the README.fedora.
Comment 3 Alec Leamas 2012-09-10 07:50:39 EDT
For my own memory, and for other who possibly would like to contribute to solve this: problems in web client parts (not an exhaustive list...).

wiki module: MPL License (subpackage?)
web_graph: contains web-canvas, bundled lib with IE only code for a canvas. Outdated?
web_calender: bundled copy of dhmtlxscheduler (http://dhtmlx.com/
Comment 4 Fedora Update System 2012-09-12 09:13:39 EDT
openerp-6.1-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/openerp-6.1-2.fc16
Comment 5 Fedora Update System 2012-09-12 09:15:34 EDT
openerp-6.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/openerp-6.1-2.fc17
Comment 6 Patrick Dubois 2012-09-12 09:21:55 EDT
Hello Alec,

I'd love to help.  The information you've provided should speed things up nicely.

I see an update has just been submitted. I'll test that first and go from there.

That IE-only code you talked about - is there much or only a smallish section ?
Comment 7 Alec Leamas 2012-09-12 09:31:49 EDT
Above all, it's not a problem. Too late, I have understood that there's a general bundling exception for client-side javascript. So it's just there, no pb. Understanding this earlier would have saved some time :)

Really good if you could do some testing...You will notice that installing openerp will pull in openerp-mpl. It's as planned, I must distribute the MPL files in a separate package until upstream fixes this.

MPL license upstream bug: https://bugs.launchpad.net/openobject-addons/+bug/1049301

I'm considering adding at least the thunderbird plugin (a binary blob) as a rpmfusion package since it can't be part of Fedora.
Comment 8 Patrick Dubois 2012-09-12 10:12:44 EDT
Ah - the bundling exception makes total sense.  I suppose I should go read up on these things somewhere as well.

Consider the testing in progress.  I can have results by Friday most likely.

Do we have a testing protocol to follow or shall I generate one ?
Comment 9 Alec Leamas 2012-09-12 10:37:18 EDT
No,  there's no test protocol. Generating one seems like a really good idea.

As does the ability to run the tests. But last time I tried, the tools were unstable (don't remember the details).

The licensing issues for the Thunderbird plugin seems to be resolved in current source, so I should be able to include it in next update
Comment 10 Jeroen van Meeuwen 2012-09-14 08:54:25 EDT
Created attachment 612855 [details]
Patch against git master HEAD to allow the package to be built and installed on EL 6 w/ EPEL

Hi Patrick,

as discussed with Alec over email, I hereby submit for inclusion a patch against git master HEAD's spec file to allow the spec file to be re-used in building OpenERP 6.1-2 for Enterprise Linux 6.

Additional dependencies not yet available through EPEL 6 include pyftpdlib (rebuilds cleanly), python-xlwt (build time requirement of antlr-python, but git master HEAD rebuilds cleanly with antlr built for el6, also from git master HEAD, when modifying the java-devel and java requirement to be >= 1:1.6.0 as opposed to >= 1:1.7.0).

For the related resulting binary RPMs that are dependencies please see http://hosted.kolabsys.com/~vanmeeuwen/
Comment 11 Patrick Dubois 2012-09-14 09:22:29 EDT
Initial quick test shows graphs and calandars functional in f17.

For Enterprise 6, would testing on centos be sufficient ?  It's what I've got for the moment. 

Would be willing to test Ent6 if I can get a hold of an ISO.
Comment 12 Alec Leamas 2012-09-14 09:52:06 EDT
From my perspective, it's more important if you could run more extensive  tests on whatever platform you have available  than to cover different platforms.  

Cheers!

--allec
Comment 13 Patrick Dubois 2012-09-14 09:56:19 EDT
Understood Alec.  Might bring to light some test cases however.  No bets as to when I'd get around to EL6 anyway...
Comment 14 Fedora Update System 2012-09-17 13:35:16 EDT
Package openerp-6.1-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openerp-6.1-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14088/openerp-6.1-2.fc17
then log in and leave karma (feedback).
Comment 15 Patrick Dubois 2012-09-23 21:25:34 EDT
Confimed this update does fix my issues.

I have provided feedback via fedora as requested.

Thanks!

Regarding the testing procedure.... I've discovered a set of RPC tests that are very interesting.   They don't currently function, but the idea is sound and I'll be working on them in the near future.

How shall I go about submitting the tests for use ?
Comment 16 Alec Leamas 2012-09-24 02:20:21 EDT
IMHO, the best option is to send them upstream i. e., to openerp. That said, I'm would appreciate if you also kept me informed, in this bug while it's still open, or in a new bug.
Comment 17 Alec Leamas 2012-09-25 06:48:56 EDT
Pushed  6.1-2 f16 and f17 update to stable. Keeping bug open until the EPEL issues are sorted out.

Patrick: Many thanks for reporting bug and testing the update! Looking forward to your work with the tests.

Jeroen: what's the status for the EPEL work?
Comment 18 Fedora Update System 2012-09-26 04:57:05 EDT
openerp-6.1-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2012-09-26 05:05:06 EDT
openerp-6.1-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.