Bug 854462 - python-django-authopenid (in F17) depends on python-django (only in F18)
python-django-authopenid (in F17) depends on python-django (only in F18)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-django-authopenid (Show other bugs)
17
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Ankur Sinha (FranciscoD)
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 02:22 EDT by Edward Z. Yang
Modified: 2012-09-21 20:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 19:01:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward Z. Yang 2012-09-05 02:22:38 EDT
On update (with django-authopenid installed):

Failed to build transaction: python-django-authopenid-1.0.1-4.fc17.noarch requires python-django
python-django-authopenid-1.0.1-4.fc17.noarch requires python-django-registration

No F17 version of Django is available: http://koji.fedoraproject.org/koji/packageinfo?packageID=13608

This applies to F16 too. python-django-registration is similarly affected (as you can see in the message)
Comment 1 Matthias Runge 2012-09-05 02:37:59 EDT
That's intentional.

The old package is called django-authopenid and was renamed (as well as the package earlier named Django to python-django-authopenid resp. python-django.

I'm closing this now, because I think you didn't knew, there is also a django-authopenid (for F17 and earlier) available. If I didn't understood that right, please reopen this ticket. 

Thanks.
Comment 2 Edward Z. Yang 2012-09-05 02:43:54 EDT
I think you are misunderstanding the situation. When a package (e.g. python-django-authopenid.fc17) obsoletes another package, yum will attempt to install the package (since that's how we manage the upgrade path.)

So the problem is that we have an F16/F17 copy of python-django-authopenid at all. It obsoletes django-authopenid, forcing itself to be installed if a system originally had django-authopenid, but the package is uninstallable on F17 because none of the other packages were renamed.
Comment 3 Matthias Runge 2012-09-05 05:51:05 EDT
Oh, I'm sorry. That rename is intended to be effective only for Fedora >= 18.

It looks like, python-django-authopenid has also been introduced in earlier versions, like f17 and also f16

Ah, ok; I reset the component to python-django-authopenid. Let's see, what we can do there. There's not much, we can do here from the python-django package. That just exists for f18 and later.
Comment 4 Edward Z. Yang 2012-09-05 11:44:59 EDT
Can you just remove the package entirely? It is uninstallable, but I don't know if it goes against Fedora policy.

Whatever you did (and I don't see any relevant changes in http://pkgs.fedoraproject.org/cgit/django-authopenid.git/ or http://pkgs.fedoraproject.org/cgit/python-django-authopenid.git/ ), the end-user visible problem (yum update doesn't work) still persists.
Comment 5 Ankur Sinha (FranciscoD) 2012-09-05 19:49:40 EDT
hello,

Would correcting the requires of the f17 and f16 package spec to "non renamed" package names fix the issue Matthias? I guess I didn't realize that the rename was only for F18+


Requires:       django django-registration

instead of 

Requires:       python-django python-django-registration

?

Thanks,
Ankur
Comment 6 Matthias Runge 2012-09-06 02:24:14 EDT
Ankur,

there are two things, you should do (if not already happened)
1. deprecate django-authopenid in all branches, where python-django-authopenid was introduced
2. introduce a conditionalized Requires:
%if 0%{?fedora} > 17
Requires:    python-django
Requires:    python-django-registration
%else
Requires:    Django django-registration
%endif

(please note the capitalized "D" in Django-requirement)

That should solve this issue.
Comment 7 Fedora Update System 2012-09-10 06:32:39 EDT
python-django-authopenid-1.0.1-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-django-authopenid-1.0.1-5.fc18
Comment 8 Fedora Update System 2012-09-10 06:44:02 EDT
python-django-authopenid-1.0.1-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-django-authopenid-1.0.1-5.fc17
Comment 9 Fedora Update System 2012-09-10 12:09:48 EDT
Package python-django-authopenid-1.0.1-5.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-django-authopenid-1.0.1-5.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13732/python-django-authopenid-1.0.1-5.fc18
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-09-17 19:01:06 EDT
python-django-authopenid-1.0.1-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2012-09-21 20:09:58 EDT
python-django-authopenid-1.0.1-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.