Bug 854467
| Summary: | Got prompt for user/password while using activation key to register | ||
|---|---|---|---|
| Product: | Red Hat Enterprise Linux 5 | Reporter: | spandey |
| Component: | subscription-manager | Assignee: | Alex Wood <awood> |
| Status: | CLOSED ERRATA | QA Contact: | Entitlement Bugs <entitlement-bugs> |
| Severity: | unspecified | Docs Contact: | |
| Priority: | unspecified | ||
| Version: | 5.9 | CC: | awood, jmolet, jsefler, kbanerje, skallesh, spandey |
| Target Milestone: | rc | ||
| Target Release: | --- | ||
| Hardware: | Unspecified | ||
| OS: | Unspecified | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | Bug Fix | |
| Doc Text: |
Cause: Attempting to register with an activation key when an organization is required but not provided.
Consequence: subscription-manager would abort with an incorrect error message.
Fix: Correct the handling of the error condition.
Result: An appropriate error message is displayed to the user.
|
Story Points: | --- |
| Clone Of: | Environment: | ||
| Last Closed: | 2013-01-08 04:03:02 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
| Bug Depends On: | |||
| Bug Blocks: | 771748 | ||
commit f34d0981a63a68b32b3f24b2fe9fe4045167b6d7
Author: Alex Wood <awood>
Date: Tue Sep 11 17:06:07 2012 -0400
854467: Use of activation keys requires an org.
Available subscription-manager-1.0.19-1+
This request was evaluated by Red Hat Product Management for inclusion in a Red Hat Enterprise Linux release. Product Management has requested further review of this request by Red Hat Engineering, for potential inclusion in a Red Hat Enterprise Linux release for currently deployed products. This request is not yet committed for inclusion in a release. Verified!! [root@localhost entitlement]# subscription-manager register --activationkey=myActivationKey2 This system is already registered. Use --force to override [root@localhost entitlement]# rpm -qa | grep subscription-manager subscription-manager-migration-1.0.19-1.el5 subscription-manager-migration-data-1.11.2.4-1.el5 subscription-manager-debuginfo-1.0.19-1.el5 subscription-manager-gui-1.0.19-1.el5 subscription-manager-1.0.19-1.el5 subscription-manager-firstboot-1.0.19-1.el5 Verified using following rpm subscription-manager-migration-data-1.11.2.4-1.el5 subscription-manager-firstboot-1.0.19-1.el5 subscription-manager-migration-1.0.19-1.el5 subscription-manager-1.0.19-1.el5 subscription-manager-gui-1.0.19-1.el5 [root@dhcp193-98 ~]# subscription-manager register --activationkey=myActivationKey2 --serverurl 10.65.193.112:8443/candlepin Error: Must provide --org with activation keys. resolving defect to verified Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. http://rhn.redhat.com/errata/RHBA-2013-0033.html |
Description of problem: Version-Release number of selected component (if applicable): How reproducible: always Prerequisites rhel5.9 with following subscription-manager rpm subscription-manager-migration-1.0.17-1.el5 subscription-manager-1.0.17-1.el5 subscription-manager-gui-1.0.17-1.el5 subscription-manager-firstboot-1.0.17-1.el5 subscription-manager-migration-data-1.11.2.4-1.el5 Steps to repro: Login to client console executed following command on console [root@dhcp193-75 pki]# subscription-manager register --activationkey=myActivationKey2 --server 10.65.193.76:8443/candlepin (without owner option) Expected Result : Proper message should display on console to register activationkey with “owner option “. Actual Result : Got following prompt for user/password [root@dhcp193-75 pki]# subscription-manager register --activationkey=myActivationKey2 --server 10.65.193.76:8443/candlepin Username: testuser1 Password: Invalid credentials. rhsm.log output : 2012-09-04 16:50:10,834 [INFO] @connection.py:508 - Using no auth 2012-09-04 16:50:10,834 [INFO] @connection.py:511 - Connection Built: host: 10.65.193.76, port: 8443, handler: /candlepin 2012-09-04 16:50:10,835 [DEBUG] @connection.py:323 - Loading CA PEM certificates from: /etc/rhsm/ca/ 2012-09-04 16:50:10,835 [DEBUG] @connection.py:305 - Loading CA certificate: '/etc/rhsm/ca/10.pem' 2012-09-04 16:50:10,836 [DEBUG] @connection.py:305 - Loading CA certificate: '/etc/rhsm/ca/candlepin-ca.pem' 2012-09-04 16:50:10,836 [DEBUG] @connection.py:305 - Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem' 2012-09-04 16:50:10,837 [DEBUG] @connection.py:305 - Loading CA certificate: '/etc/rhsm/ca/candlepin.pem' 2012-09-04 16:50:10,837 [DEBUG] @connection.py:305 - Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem' 2012-09-04 16:50:10,837 [DEBUG] @connection.py:344 - Making request: GET /candlepin/status/ 2012-09-04 16:50:10,862 [DEBUG] @connection.py:357 - Response status: 200 2012-09-04 16:50:10,864 [DEBUG] @profile.py:95 - Loading current RPM profile. 2012-09-04 16:50:10,990 [INFO] @managercli.py:252 - Client Versions: {'python-rhsm': '1.0.7-1.el5', 'subscription-manager': '1.0.17-1.el5'} 2012-09-04 16:50:10,991 [INFO] @connection.py:498 - Using certificate authentication: key = /etc/pki/consumer/key.pem, cert = /etc/pki/consumer/cert.pem, ca = /etc/rhsm/ca/, insecure = False 2012-09-04 16:50:10,991 [INFO] @connection.py:511 - Connection Built: host: 10.65.193.76, port: 8443, handler: /candlepin 2012-09-04 16:50:10,991 [DEBUG] @managercli.py:261 - Server Versions: Not registered, unable to check server version 2012-09-04 16:50:10,992 [INFO] @managercli.py:252 - Client Versions: {'python-rhsm': '1.0.7-1.el5', 'subscription-manager': '1.0.17-1.el5'} 2012-09-04 16:50:11,046 [INFO] @connection.py:508 - Using no auth 2012-09-04 16:50:11,047 [INFO] @connection.py:511 - Connection Built: host: 10.65.193.76, port: 8443, handler: /candlepin 2012-09-04 16:50:18,317 [ERROR] @rhsmcertd-worker:35 - Either the consumer is not registered or the certificates are corrupted. Certificate update using daemon failed. 2012-09-04 16:50:19,905 [DEBUG] @connection.py:323 - Loading CA PEM certificates from: /etc/rhsm/ca/ 2012-09-04 16:50:19,907 [DEBUG] @connection.py:305 - Loading CA certificate: '/etc/rhsm/ca/10.pem' 2012-09-04 16:50:19,908 [DEBUG] @connection.py:305 - Loading CA certificate: '/etc/rhsm/ca/candlepin-ca.pem' 2012-09-04 16:50:19,909 [DEBUG] @connection.py:305 - Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem' 2012-09-04 16:50:19,910 [DEBUG] @connection.py:305 - Loading CA certificate: '/etc/rhsm/ca/candlepin.pem' 2012-09-04 16:50:19,911 [DEBUG] @connection.py:305 - Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem' 2012-09-04 16:50:19,913 [DEBUG] @connection.py:344 - Making request: GET /candlepin/users/testuser1/owners 2012-09-04 16:50:19,927 [DEBUG] @connection.py:357 - Response status: 401 2012-09-04 16:50:19,927 [ERROR] @managercli.py:950 - Invalid credentials. Traceback (most recent call last): File "/usr/share/rhsm/subscription_manager/managercli.py", line 938, in _do_command owner_key = self._determine_owner_key(admin_cp) File "/usr/share/rhsm/subscription_manager/managercli.py", line 1039, in _determine_owner_key owners = cp.getOwnerList(self.username) File "/usr/lib64/python2.4/site-packages/rhsm/connection.py", line 660, in getOwnerList return self.conn.request_get(method) File "/usr/lib64/python2.4/site-packages/rhsm/connection.py", line 400, in request_get return self._request("GET", method) File "/usr/lib64/python2.4/site-packages/rhsm/connection.py", line 362, in _request self.validateResponse(result) File "/usr/lib64/python2.4/site-packages/rhsm/connection.py", line 387, in validateResponse raise RestlibException(response['status'], error_msg) RestlibException: Invalid credentials.