This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 854485 - [RESTAPI] Can't create a VM cloned from template
[RESTAPI] Can't create a VM cloned from template
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Michael Pasternak
Attila Darazs
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 03:04 EDT by Michael Pasternak
Modified: 2014-01-12 19:37 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-03 03:39:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Pasternak 2012-09-05 03:04:19 EDT
On 09/04/2012 06:15 PM, Simon Grinberg wrote:
> 13. CLI: Can't create a VM cloned from template, --disks-clone accepts any value and then ignores it.
> 
> [241] create vm --template-name BaseRHEL6 --name myRHELCloned1 --cluster-name Default --disks-clone
> [246] create vm --template-name BaseRHEL6 --name myRHELCloned --cluster-name Default --disks-clone thin
> [247] create vm --template-name BaseRHEL6 --name myRHELCloned4 --cluster-name Default --disks-clone true 
> [248] create vm --template-name BaseRHEL6 --name myRHELCloned5 --cluster-name Default --disks-clone True
> 
> All accepted and ignored, VM is always a snapshot from the template, no problem with doing clone from Template in the GUI.
Comment 2 Michael Pasternak 2012-10-03 03:39:25 EDT
i cannot reproduce this

[oVirt shell (connected)]# add vm --template-name iscsi_desktop_tmpl --cluster-name Default_iscsi --name aaa --disks-clone true

produce correct xml.

<vm>\n
    <name>aaa</name>\n
    <cluster>\n
        <name>Default_iscsi</name>\n
    </cluster>\n
    <template>\n
        <name>iscsi_desktop_tmpl</name>\n
    </template>\n
    <disks>\n
        <clone>true</clone>\n
    </disks>\n
</vm>\n'

Note You need to log in before you can comment on or make changes to this bug.