Bug 854487 - [RFE] add timeout before joining the channels if auto identify is set up
[RFE] add timeout before joining the channels if auto identify is set up
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: konversation (Show other bugs)
17
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 03:10 EDT by Martin Banas
Modified: 2012-09-05 07:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-05 07:05:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 132608 None None None 2012-09-05 07:05:17 EDT

  None (edit)
Description Martin Banas 2012-09-05 03:10:07 EDT
Description of problem:

Automatic identify in konversation happens the same time as joining the channels. This means, that I'm not able to join channels which require identify (like #fedora).


Version-Release number of selected component (if applicable):
konversation-1.4-2.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1. Setup automatic identify in konversation to FreeNode channel
2. Setup automated connecting to #fedora channel
3. Restart the konversation
  
Actual results:
Unable to autojoin #fedora channel since user is not identified at this moment. Every time I need to manually join this channel.

Expected results:
If there was some timeout (or timeout option), or for example some rule to join the channels after automatic identify, this issue would be resolved.

Additional info:
Comment 1 Kevin Kofler 2012-09-05 07:05:17 EDT
Set nickname:password as your server password for Freenode, that way it will be sent immediately when connecting. That's a hack supported specifically by Freenode to work around this problem: http://freenode.net/faq.shtml#nicksetup point 7.

The next release of Konversation (1.5) will include an even cleaner solution for the problem: http://userbase.kde.org/Konversation/Configuring_SASL_authentication (Server-side support on Freenode is already there: http://freenode.net/faq.shtml#nocloakonjoin )

Note You need to log in before you can comment on or make changes to this bug.