Bug 854504 - SELinux is preventing pwconv from 'read' accesses on the file /proc/<pid>/mounts.
SELinux is preventing pwconv from 'read' accesses on the file /proc/<pid>/mou...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:66d6d4805ac97d5acd1102cd2b5...
:
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-09-05 04:23 EDT by Kamil Páral
Modified: 2012-09-12 19:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-12 19:51:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-09-05 04:23 EDT, Kamil Páral
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-09-05 04:23 EDT, Kamil Páral
no flags Details
File: description (2.11 KB, text/plain)
2012-09-05 04:23 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-09-05 04:23:51 EDT
Description of problem:


Version-Release number of selected component:
(null)

Additional info:
libreport version: 2.0.12
kernel:         3.6.0-0.rc2.git2.1.fc18.i686
Comment 1 Kamil Páral 2012-09-05 04:23:53 EDT
Created attachment 609891 [details]
File: type
Comment 2 Kamil Páral 2012-09-05 04:23:56 EDT
Created attachment 609892 [details]
File: hashmarkername
Comment 3 Kamil Páral 2012-09-05 04:23:58 EDT
Created attachment 609893 [details]
File: description
Comment 4 Kamil Páral 2012-09-05 04:30:56 EDT
I see this alert when doing a system installation from Fedora 18 Alpha TC5 Live GNOME i686. After the installation has finished, this was in the list of alerts.

Proposing as Final blocker. Our criteria only speaks about installed system boot, not about selinux alerts during installation. I don't know whether it applies:
" In most cases, there must be no SELinux 'AVC: denied' messages or abrt crash notifications on initial boot and subsequent login (see Blocker_Bug_FAQ) "
https://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria

We should either fix the alert or disable SELinux troubleshooter when Live is run, so that the users are not bothered with cryptic messages.
Comment 5 Miroslav Grepl 2012-09-06 07:46:09 EDT
Kamil, 
could you attach raw AVC msgs from the /var/log/audit/audit.log for all your bugs related to Alpha TC5 Live?
Comment 6 Miroslav Grepl 2012-09-06 08:09:23 EDT
I am interested in syscall field.
Comment 7 Kamil Páral 2012-09-07 08:37:25 EDT
I used Alpha TC6 Live, but it seems to behave exactly same. Here is the excerpt from audit.log:

type=AVC msg=audit(1347019807.634:88): avc:  denied  { read } for  pid=3588 comm="pwconv" path="/proc/2177/mounts" dev="proc" ino=24633 scontext=unconfined_u:unconfined_r:sysadm_passwd_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=file
type=AVC msg=audit(1347019807.634:89): avc:  denied  { read write } for  pid=3588 comm="pwconv" path=2F746D702F6666695973654F5A50202864656C6574656429 dev="tmpfs" ino=25047 scontext=unconfined_u:unconfined_r:sysadm_passwd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_tmp_t:s0 tclass=file
type=AVC msg=audit(1347019807.634:90): avc:  denied  { read write } for  pid=3588 comm="pwconv" path="/dev/mapper/control" dev="devtmpfs" ino=6286 scontext=unconfined_u:unconfined_r:sysadm_passwd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:lvm_control_t:s0 tclass=chr_file
type=AVC msg=audit(1347019809.936:91): avc:  denied  { read write } for  pid=3624 comm="restorecon" path="/dev/mapper/control" dev="devtmpfs" ino=6286 scontext=unconfined_u:unconfined_r:setfiles_t:s0-s0:c0.c1023 tcontext=system_u:object_r:lvm_control_t:s0 tclass=chr_file
Comment 8 Miroslav Grepl 2012-09-10 02:50:40 EDT
rpm -q selinux-policy
Comment 9 Kamil Páral 2012-09-10 04:43:15 EDT
(In reply to comment #8)
> rpm -q selinux-policy

selinux-policy-3.11.1-7.fc18.noarch
Comment 10 Miroslav Grepl 2012-09-11 01:54:40 EDT
So old F18 policy. The latest F18 policy build should be used.
Comment 11 Fedora Update System 2012-09-12 08:27:39 EDT
selinux-policy-3.11.1-18.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-13554/selinux-policy-3.11.1-18.fc18
Comment 12 Fedora Update System 2012-09-12 15:12:33 EDT
Package selinux-policy-3.11.1-18.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.11.1-18.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13554/selinux-policy-3.11.1-18.fc18
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2012-09-12 19:51:25 EDT
selinux-policy-3.11.1-18.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.