Bug 854508 - Logged in to admin user on SAM WebUI inappropriately along with errors
Logged in to admin user on SAM WebUI inappropriately along with errors
Status: CLOSED UPSTREAM
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Eric Sammons
SAM QE List
: Triaged
Depends On:
Blocks: sam12-tracker
  Show dependency treegraph
 
Reported: 2012-09-05 04:28 EDT by Tazim Kolhar
Modified: 2016-04-25 20:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-05 16:18:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
login admin (70.98 KB, image/png)
2012-09-05 04:28 EDT, Tazim Kolhar
no flags Details
Admin login SAM WebUI (60.02 KB, image/png)
2012-09-18 04:18 EDT, Tazim Kolhar
no flags Details

  None (edit)
Description Tazim Kolhar 2012-09-05 04:28:55 EDT
Created attachment 609900 [details]
login admin

Description of problem:
login to WEBUI using admin user failed even after successful installation 
and deployment

Version-Release number of selected component (if applicable):
katello-selinux-1.1.1-1.fc16.noarch
katello-configure-1.1.7-1.git.119.b594042.fc16.noarch
katello-common-1.1.9-1.git.128.be134c2.fc16.noarch
katello-cli-common-1.1.5-1.git.129.be134c2.fc16.noarch
katello-glue-pulp-1.1.9-1.git.128.be134c2.fc16.noarch
katello-1.1.9-1.git.128.be134c2.fc16.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.1.8-1.fc16.noarch
katello-glue-foreman-1.1.9-1.git.128.be134c2.fc16.noarch
katello-cli-headpin-1.1.1-1.git.59.e8fe8d3.fc16.noarch
katello-all-1.1.9-1.git.128.be134c2.fc16.noarch
katello-glue-candlepin-1.1.9-1.git.128.be134c2.fc16.noarch
katello-repos-1.1.2-1.fc16.noarch


How reproducible:
yum install -y katello-all thumbslug
katello-configure --deployment=headpin
rpm -ev --nodeps katello-cli
yum install katello-cli-headpin  

Steps to Reproduce:
1.yum install -y katello-all thumbslug
2.katello-configure --deployment=headpin
3.rpm -ev --nodeps katello-cli
4.yum install katello-cli-headpin

  
Actual results:
Login to admin was done inappropriately
screen shot attached

Expected results:

login to UI using admin user should work

Additional info:
Comment 1 Eric Sammons 2012-09-13 10:05:43 EDT
Can you please try again using the following steps:

1. yum install -y katello-headpin-all
2. katello-configure --deployment=headpin
3. Attempt to login.
Comment 2 Eric Sammons 2012-09-13 10:06:16 EDT
Unable to reproduce with katello-common-1.1.10 and katello-common-1.1.11.
Comment 3 Tazim Kolhar 2012-09-18 04:18:59 EDT
Created attachment 613894 [details]
Admin login SAM WebUI

Retested the login:

# rpm -qa | grep katello-common
katello-common-1.1.12-1.git.26.d683e16.fc16.noarch


Able to login using the credentials admin/admin

Note You need to log in before you can comment on or make changes to this bug.