Bug 854512 - root has a password on Live
root has a password on Live
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
RejectedBlocker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 04:39 EDT by Kamil Páral
Modified: 2012-09-05 13:25 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-05 13:25:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2012-09-05 04:39:03 EDT
Description of problem:
In Fedora 17 and prior, root had no password set on LiveCDs, therefore you could easily do "su -" from liveuser account and get access to the whole system. But with F18 Alpha TC5 Live GNOME, "su -" asks for root password. That invalidates the point of LiveCD, where you need root to perform some actions (like system rescues, problem debugging, etc).

Version-Release number of selected component (if applicable):
F18 Alpha TC5 Live GNOME i686

How reproducible:
always

Steps to Reproduce:
1. su -
2. password is asked
Comment 1 Kamil Páral 2012-09-05 04:42:16 EDT
I propose this for discussion as Alpha blocker.

Rationale: Public Alpha release is used for wide testing. A lot of people report various problems. It will be impossible to e.g. attach important log files (/var/log/messages) without root access. These media are also used for Test Days, that sometimes require user to use yum or other root-only commands.
Comment 2 Brian Lane 2012-09-05 09:23:05 EDT
root password removal is handled by the spin kickstart.
Comment 3 Kevin Fenzi 2012-09-05 10:25:54 EDT
Yeah, in the nightly composes I do see: 

DEBUG util.py:257:  Removing password for user root.
DEBUG util.py:257:  passwd: Success

So, not sure what would have caused this. 

Can you see what /etc/shadow and /etc/passwd have for root?
Comment 4 Kamil Páral 2012-09-05 10:52:53 EDT
Interesting note - TC5 KDE composes don't have root password.
Comment 5 Adam Williamson 2012-09-05 13:17:52 EDT
Discussed at 2012-09-05 blocker review meeting. Rejected as a blocker, as akshayvyas said this worked fine in his testing, and Kamil re-tested and found it worked. kamil will test more extensively to see if this is specific to a system or an arch or only occurs periodically, but for now, it's rejected as a blocker.
Comment 6 Kamil Páral 2012-09-05 13:25:28 EDT
I don't know how it is possible, but I can't reproduce it anymore. Is this matrix? Am I real?

Sorry for confusion:
http://bit.ly/RlFUYQ

I'll reopen if I see it again.

Note You need to log in before you can comment on or make changes to this bug.