Bug 854527 - VDSM task disappears when deleting vm with multiple disks while spm reboots will leave vm in image locked
VDSM task disappears when deleting vm with multiple disks while spm reboots w...
Status: CLOSED DUPLICATE of bug 854308
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: mkublin
infra
:
Depends On: 761050
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 05:22 EDT by Maor
Modified: 2016-02-10 14:15 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 761050
Environment:
Last Closed: 2012-10-21 05:53:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Maor 2012-09-05 05:25:25 EDT
The issue that should be handled here, is with task 00f09763-b45c-49f6-a143-65bae9c80485 disappears from SPM after restart.
Comment 3 Barak 2012-09-11 10:51:58 EDT
Maor - restart SPM = restart vdsm(SPM) or reboot host?
Comment 4 Maor 2012-09-12 04:01:38 EDT
The original reproduce steps were rebooting, so I guess it's better to go on the safe side and perform a reboot on the host,
Although I think restart vdsm(SPM) might also work,
The key is that when a new host is selected to be SPM, it does not see the task which was created in the previous SPM.

-- Task in SPM
00f09763-b45c-49f6-a143-65bae9c80485::DEBUG::2011-12-07 17:24:49,640::task::495::TaskManager.Task::(_debug) Task 00f09763-b45c-49f6-a143-65bae9c80485: ref 0 aborting False
00f09763-b45c-49f6-a143-65bae9c80485::DEBUG::2011-12-07 17:24:49,640::threadPool::47::Misc.ThreadPool::(setRunningTask) Number of running tasks: 0
.... -- new SPM reelacted
MainThread::INFO::2011-12-07 17:26:48,712::vdsm::71::vds::(run) I am the actual vdsm 4.9-112
...-- No task found.
Thread-80::INFO::2011-12-07 17:27:26,535::dispatcher::94::Storage.Dispatcher.Protect::(run) Run and protect: stopTask, args: ( taskID=00f09763-b45c-49f6-a143-65bae9c80485)
Thread-80::DEBUG::2011-12-07 17:27:26,535::task::495::TaskManager.Task::(_debug) Task b9889003-b3d7-4f7f-aac4-58af58b0be7c: moving from state init -> state preparing
Thread-80::DEBUG::2011-12-07 17:27:26,536::taskManager::128::TaskManager::(stopTask) Entry. taskID: 00f09763-b45c-49f6-a143-65bae9c80485
Thread-80::ERROR::2011-12-07 17:27:26,536::task::868::TaskManager.Task::(_setError) Unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/task.py", line 876, in _run
    return fn(*args, **kargs)
  File "/usr/share/vdsm/storage/hsm.py", line 960, in public_stopTask
    return self.taskMng.stopTask(taskID=taskID, force=force)
  File "/usr/share/vdsm/storage/taskManager.py", line 129, in stopTask
    t = self.__getTask(taskID)
  File "/usr/share/vdsm/storage/taskManager.py", line 62, in __getTask
    raise se.UnknownTask(taskID)
UnknownTask: Task id unknown: ('00f09763-b45c-49f6-a143-65bae9c80485',)
Thread-80::DEBUG::2011-12-07 17:27:26,538::task::495::TaskManager.Task::(_debug) Task b9889003-b3d7-4f7f-aac4-58af58b0be7c: Task._run: b9889003-b3d7-4f7f-aac4-58af58b0be7c ('00f09763-b45c-49f6-a143-65bae9c80485',) {} failed - stopping task
Comment 5 Maor 2012-09-12 04:03:48 EDT
Dafna, is restart vdsm process of SPM, also reproduce this issue, or only rebooting?
Comment 6 Dafna Ron 2012-09-12 04:06:18 EDT
no. but vlad is working on something similar to this bug when removing floating disks. adding him to this bug.
Comment 7 Yaniv Bronhaim 2012-10-01 14:13:14 EDT
does the patch http://gerrit.ovirt.org/7757 solve the bug? seems like it does the work. can you verify it?
Comment 9 mkublin 2012-10-21 05:53:11 EDT

*** This bug has been marked as a duplicate of bug 854308 ***

Note You need to log in before you can comment on or make changes to this bug.