Bug 854532 - [abrt] evolution-data-server-3.4.4-2.fc17: ldap_ntlm_bind: Process /usr/libexec/evolution-addressbook-factory was killed by signal 6 (SIGABRT)
[abrt] evolution-data-server-3.4.4-2.fc17: ldap_ntlm_bind: Process /usr/libex...
Status: CLOSED DUPLICATE of bug 851624
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:139a632a7e3d939da778e7dbfcd...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 05:36 EDT by srh
Modified: 2012-09-06 05:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-06 05:47:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (2.17 KB, text/plain)
2012-09-05 05:36 EDT, srh
no flags Details
File: environ (1016 bytes, text/plain)
2012-09-05 05:36 EDT, srh
no flags Details
File: backtrace (29.21 KB, text/plain)
2012-09-05 05:36 EDT, srh
no flags Details
File: limits (1.29 KB, text/plain)
2012-09-05 05:36 EDT, srh
no flags Details
File: cgroup (130 bytes, text/plain)
2012-09-05 05:36 EDT, srh
no flags Details
File: maps (53.74 KB, text/plain)
2012-09-05 05:36 EDT, srh
no flags Details
File: dso_list (11.30 KB, text/plain)
2012-09-05 05:37 EDT, srh
no flags Details
File: var_log_messages (1.36 KB, text/plain)
2012-09-05 05:37 EDT, srh
no flags Details
File: open_fds (653 bytes, text/plain)
2012-09-05 05:37 EDT, srh
no flags Details

  None (edit)
Description srh 2012-09-05 05:36:43 EDT
Description of problem:
Updated to:

Name        : evolution
Arch        : x86_64
Version     : 3.4.4
Release     : 1.fc17
..........
Name        : evolution-exchange
Arch        : x86_64
Version     : 3.4.4
Release     : 2.fc17
.........
Name        : openldap
Arch        : x86_64
Version     : 2.4.32
Release     : 2.fc17

Emails show up fine from exchange server using evolution-exchange. Switching Evo to Contacts, viewing exchange server Contacts starts evolution-addressbook-factory, which then crashes after a few seconds (it happens every time). No contacts show up in Evo.
Exchange contacts showed up ok under Evo 3.4.3.


Version-Release number of selected component:
evolution-data-server-3.4.4-2.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
backtrace_rating: 4
cmdline:        /usr/libexec/evolution-addressbook-factory
crash_function: ldap_ntlm_bind
kernel:         3.5.3-1.fc17.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #4 ldap_ntlm_bind at /usr/lib64/evolution-exchange/3.4/libexchange.so.0
: #5 ntlm_bind at e2k-global-catalog.c
: #6 connect_ldap at e2k-global-catalog.c
: #7 get_ldap_connection at e2k-global-catalog.c
: #8 get_gc_connection at e2k-global-catalog.c
: #9 gc_search at e2k-global-catalog.c
: #10 e2k_global_catalog_lookup at e2k-global-catalog.c
: #11 exchange_account_connect at exchange-account.c
: #12 e_book_backend_exchange_authenticate_user at e-book-backend-exchange.c
: #13 operation_thread at e-data-book.c
Comment 1 srh 2012-09-05 05:36:46 EDT
Created attachment 609942 [details]
File: core_backtrace
Comment 2 srh 2012-09-05 05:36:48 EDT
Created attachment 609943 [details]
File: environ
Comment 3 srh 2012-09-05 05:36:51 EDT
Created attachment 609944 [details]
File: backtrace
Comment 4 srh 2012-09-05 05:36:53 EDT
Created attachment 609945 [details]
File: limits
Comment 5 srh 2012-09-05 05:36:55 EDT
Created attachment 609947 [details]
File: cgroup
Comment 6 srh 2012-09-05 05:36:58 EDT
Created attachment 609948 [details]
File: maps
Comment 7 srh 2012-09-05 05:37:00 EDT
Created attachment 609949 [details]
File: dso_list
Comment 8 srh 2012-09-05 05:37:02 EDT
Created attachment 609950 [details]
File: var_log_messages
Comment 9 srh 2012-09-05 05:37:04 EDT
Created attachment 609951 [details]
File: open_fds
Comment 10 srh 2012-09-05 05:50:49 EDT
This may be related to:
https://bugzilla.redhat.com/show_bug.cgi?id=851624


Now having updated to:

Name        : evolution
Arch        : x86_64
Version     : 3.4.4
Release     : 1.fc17

Name        : evolution-exchange
Arch        : x86_64
Version     : 3.4.4
Release     : 2.fc17

so as to work properly with:

Name        : openldap
Arch        : x86_64
Version     : 2.4.32
Release     : 2.fc17

Evo now starts up fine, so Bug 851624 seems to be fixed in terms of Evo at least starting. However, the exchange Contacts don't work, when they used to under Evo 3.4.3.
Comment 11 Milan Crha 2012-09-06 05:47:28 EDT
Thanks for a bug report. Let's move this under bug #851624.

*** This bug has been marked as a duplicate of bug 851624 ***

Note You need to log in before you can comment on or make changes to this bug.