Bug 854581 - New snapshot is not created when child channel is added/removed via API.
New snapshot is not created when child channel is added/removed via API.
Status: CLOSED DUPLICATE of bug 854571
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
550
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Jan Pazdziora
Red Hat Satellite QA List
:
Depends On:
Blocks: 819027
  Show dependency treegraph
 
Reported: 2012-09-05 07:24 EDT by Dimitar Yordanov
Modified: 2013-07-08 11:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-08 11:13:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dimitar Yordanov 2012-09-05 07:24:47 EDT
Description of problem:
 New snapshot is not created when child channel is added/removed via API. 

Version-Release number of selected component (if applicable):
Satellite [541|550]

How reproducible:
100%

Steps to Reproduce:
1. Create Custom Base Channel and Custom Child Channel.
2. Register a System.
3. Set the "Custom Base Channel" as a Base channel for the system.
4. Add "Custom Child Channel" to  the system using API call 

 system.setChildChannels(string sessionKey, int serverId, array[string channelLabel])

The same thing Base Channel.
 system.setBaseChannel(string sessionKey, int serverId, string channelLabel)


Actual results:
When the child channel is added  new snapshot is not created in
Systems -> the System profile -> Provisioning -> Snapshots

Expected results:
New snapshot is  created.

Additional info:
The same issue is reported for spacewalk-channel (backend).
Bug 854571 - New snapshot is not created when child channel is added/removed via spacewalk-channel.
Comment 1 Clifford Perry 2013-07-08 11:13:45 EDT

*** This bug has been marked as a duplicate of bug 854571 ***

Note You need to log in before you can comment on or make changes to this bug.