Bug 854636 - [glusterfs-3.3.0qa27]: dmesg says there is a readdir loop
[glusterfs-3.3.0qa27]: dmesg says there is a readdir loop
Status: CLOSED DUPLICATE of bug 770250
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs-server (Show other bugs)
2.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Vijay Bellur
Rahul Hinduja
:
Depends On: 802416
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 09:34 EDT by Vidya Sakar
Modified: 2013-03-03 21:07 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 802416
Environment:
Last Closed: 2013-02-26 03:34:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2012-09-05 09:34:20 EDT
+++ This bug was initially created as a clone of Bug #802416 +++

Description of problem:
3 replica pure replicate volume. 3 fuse clients and 3 nfs clients, each executing different tools such as ping_pong, rdd, fs-perf-test etc.

When dmesg was executed it reported readdir loop detected by nfs client.

NFS: directory /char_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 6775
NFS: directory /char_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 9754
NFS: directory / contains a readdir loop.  Please contact your server vendor.  Offending cookie: 6161
NFS: directory /file_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 6661
NFS: directory /file_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 9925
NFS: directory /char_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 4967
NFS: directory /char_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 7700
NFS: directory /char_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 10326
NFS: directory /char_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 12362
NFS: directory / contains a readdir loop.  Please contact your server vendor.  Offending cookie: 9248
NFS: directory /pipe_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 5248
NFS: directory /pipe_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 9150
NFS: directory /file_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 6126
NFS: directory /file_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 8692
NFS: directory /file_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 12036
NFS: directory /block_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 6676
NFS: directory /block_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 7988
NFS: directory /block_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 10254
NFS: directory /block_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 12404
NFS: directory /char_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 8371
NFS: directory /char_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 10171
NFS: directory /block_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 10632
NFS: directory /block_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 8865
NFS: directory /char_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 8527
NFS: directory /block_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 7751
NFS: directory /char_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 10455
NFS: directory /char_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 3742
NFS: directory /char_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 9847
NFS: directory /block_dir contains a readdir loop.  Please contact your server vendor.  Offending cookie: 13338
nfs: server 10.16.156.9 not responding, still trying
NFS: directory / contains a readdir loop.  Please contact your server vendor.  Offending cookie: 3140
nfs: server 10.16.156.9 not responding, still trying

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

--- Additional comment from amarts@redhat.com on 2012-03-12 12:47:59 EDT ---

Need to check with NFS team for the meaning of this.

--- Additional comment from sac@redhat.com on 2012-03-13 09:18:43 EDT ---

I could hit the same issue with multiple rename operations. Distriubute setup with 4 nodes.

--- Additional comment from jlayton@redhat.com on 2012-03-15 09:50:36 EDT ---

That generally means that the NFS server is sending duplicate continuation
cookies in READDIR calls. Note though that there is a bug in recent RHEL6
client kernels that can make this message pop more frequently than it should.
See bug 770250.

--- Additional comment from vbellur@redhat.com on 2012-03-31 11:38:42 EDT ---

Can you please confirm if this bug is seen with RHEL 5.x clients?

--- Additional comment from vbellur@redhat.com on 2012-05-18 08:51:32 EDT ---

Not seen with 5.x clients. Hence removing the target milestone.
Comment 2 Ric Wheeler 2012-09-05 10:15:54 EDT
Is this fixed by:

https://bugzilla.redhat.com/show_bug.cgi?id=770250

Why is this BZ "ON_QA" without a fix?
Comment 3 Amar Tumballi 2012-12-05 07:20:45 EST
making the status and assignee same as the source bug in upstream.
Comment 4 nayfield 2013-01-15 17:16:26 EST
Confirmed that bz770250 was the culprit on my system, can reproduce with kernel-2.6.32-220.13.1.el6.x86_64 but upgrading to kernel-2.6.32-220.17.1.el6.x86_64 resolves the problem.
Comment 5 Vijay Bellur 2013-02-26 03:34:25 EST

*** This bug has been marked as a duplicate of bug 770250 ***

Note You need to log in before you can comment on or make changes to this bug.