This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 854643 - XklWrapperError: Failed to remove layout 'us ()'
XklWrapperError: Failed to remove layout 'us ()'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
abrt_hash:d866e4abd3c76558f959b7ee561...
:
Depends On:
Blocks: F18Beta-accepted/F18BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-09-05 09:40 EDT by Reartes Guillermo
Modified: 2012-09-28 16:11 EDT (History)
5 users (show)

See Also:
Fixed In Version: anaconda-18.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-28 16:11:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: ifcfg.log (697 bytes, text/plain)
2012-09-05 09:40 EDT, Reartes Guillermo
no flags Details
File: anaconda-tb (201.79 KB, text/plain)
2012-09-05 09:40 EDT, Reartes Guillermo
no flags Details
File: environ (771 bytes, text/plain)
2012-09-05 09:41 EDT, Reartes Guillermo
no flags Details
File: type (9 bytes, text/plain)
2012-09-05 09:41 EDT, Reartes Guillermo
no flags Details
File: storage.log (68.29 KB, text/plain)
2012-09-05 09:41 EDT, Reartes Guillermo
no flags Details
File: version (12 bytes, text/plain)
2012-09-05 09:41 EDT, Reartes Guillermo
no flags Details
File: program.log (24.86 KB, text/plain)
2012-09-05 09:41 EDT, Reartes Guillermo
no flags Details
File: product (6 bytes, text/plain)
2012-09-05 09:41 EDT, Reartes Guillermo
no flags Details
File: syslog (78.03 KB, text/plain)
2012-09-05 09:41 EDT, Reartes Guillermo
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-09-05 09:41 EDT, Reartes Guillermo
no flags Details
File: anaconda.log (1.94 KB, text/plain)
2012-09-05 09:41 EDT, Reartes Guillermo
no flags Details
File: release (24 bytes, text/plain)
2012-09-05 09:41 EDT, Reartes Guillermo
no flags Details
File: description (589 bytes, text/plain)
2012-09-05 09:41 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-09-05 09:40:44 EDT
Description of problem:


Version-Release number of selected component:
anaconda-18.6.4

Additional info:
libreport version: 2.0.12
cmdline:        initrd=initrd.img  xdriver=vesa nomodeset quiet BOOT_IMAGE=vmlinuz 
kernel:         3.6.0-0.rc2.git2.1.fc18.x86_64
Comment 1 Reartes Guillermo 2012-09-05 09:40:47 EDT
Created attachment 610041 [details]
File: ifcfg.log
Comment 2 Reartes Guillermo 2012-09-05 09:40:58 EDT
Created attachment 610042 [details]
File: anaconda-tb
Comment 3 Reartes Guillermo 2012-09-05 09:41:01 EDT
Created attachment 610044 [details]
File: environ
Comment 4 Reartes Guillermo 2012-09-05 09:41:04 EDT
Created attachment 610046 [details]
File: type
Comment 5 Reartes Guillermo 2012-09-05 09:41:07 EDT
Created attachment 610047 [details]
File: storage.log
Comment 6 Reartes Guillermo 2012-09-05 09:41:11 EDT
Created attachment 610048 [details]
File: version
Comment 7 Reartes Guillermo 2012-09-05 09:41:14 EDT
Created attachment 610049 [details]
File: program.log
Comment 8 Reartes Guillermo 2012-09-05 09:41:17 EDT
Created attachment 610050 [details]
File: product
Comment 9 Reartes Guillermo 2012-09-05 09:41:21 EDT
Created attachment 610051 [details]
File: syslog
Comment 10 Reartes Guillermo 2012-09-05 09:41:29 EDT
Created attachment 610052 [details]
File: hashmarkername
Comment 11 Reartes Guillermo 2012-09-05 09:41:31 EDT
Created attachment 610053 [details]
File: anaconda.log
Comment 12 Reartes Guillermo 2012-09-05 09:41:34 EDT
Created attachment 610054 [details]
File: release
Comment 13 Reartes Guillermo 2012-09-05 09:41:36 EDT
Created attachment 610055 [details]
File: description
Comment 14 Reartes Guillermo 2012-09-05 09:49:50 EDT
Additional info:

I have a Spanish keyboard.
So, normally i added the Spanish keyboard and then removed the English one.

But then i found that by just pressing the "-" (minus) remove keyboard in anaconda gives the "add a keyboard layout". So i started to change my keyboard with such a method (a lot of times). I fact, until today, i though it was a feature. It works most of the time, except today. Tried again and could not reproduce it.
Comment 15 Reartes Guillermo 2012-09-10 22:32:35 EDT
I reproduced it:

0) Enter keyboard layout menu

1) Select "English" (default) with the mouse

2) Click the '-' minus button

3 Start to type "Spanish" (in my case), but do not complete the word:
'spa' 

4) then press ALT+A (for 'add')

5) bang!

So comment #14 was not accurate.
Comment 16 Reartes Guillermo 2012-09-10 22:33:22 EDT
I forgot to add that i reproduced it with F18a rc1 (anaconda 18.6.7)
Comment 17 Reartes Guillermo 2012-09-18 16:42:31 EDT
It still happens with F18a rc3 (anaconda 18.6.8)
I propose it as a blocker for beta.
Comment 18 Vratislav Podzimek 2012-09-19 04:14:50 EDT
(In reply to comment #17)
> It still happens with F18a rc3 (anaconda 18.6.8)
> I propose it as a blocker for beta.
Since this was not a blocker for alpha, the patch was not included in builds for alpha.
Comment 19 Adam Williamson 2012-09-26 15:27:38 EDT
Discussed at 2012-09-26 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-09-26/f18-beta-blocker-review-1.2012-09-26-16.03.log.txt . Rejected as a blocker because it seems a bit too difficult to hit, by the description, you have to do things a very specific way to hit this crash. Accepted as NTH, as anaconda crashers are usually worth fixing. In practice, this will be fixed for Beta, since the fix is in already. It is probably in 18.8 or 18.9 already.
Comment 20 Vratislav Podzimek 2012-09-27 04:24:48 EDT
(In reply to comment #19)
> Discussed at 2012-09-26 blocker review meeting:
> http://meetbot.fedoraproject.org/fedora-qa/2012-09-26/f18-beta-blocker-
> review-1.2012-09-26-16.03.log.txt . Rejected as a blocker because it seems a
> bit too difficult to hit, by the description, you have to do things a very
> specific way to hit this crash. Accepted as NTH, as anaconda crashers are
> usually worth fixing. In practice, this will be fixed for Beta, since the
> fix is in already. It is probably in 18.8 or 18.9 already.
Yeah, it is in 18.8, I just forgot to add "Fixed in version" info.
Comment 21 Adam Williamson 2012-09-28 16:11:54 EDT
18.8 went stable already, so we can close this.

Note You need to log in before you can comment on or make changes to this bug.