Bug 854650 - Arequal check sum mismatch after remove brick start operation from distributed-stripe volume
Arequal check sum mismatch after remove brick start operation from distribute...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Amar Tumballi
shylesh
:
Depends On: 823664
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 09:44 EDT by Vidya Sakar
Modified: 2013-12-18 19:08 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 823664
Environment:
Last Closed: 2013-09-23 18:33:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2012-09-05 09:44:36 EDT
+++ This bug was initially created as a clone of Bug #823664 +++

Description of problem:
After migrating data from a distributed-stripe using remove-brick mount point shows different checksum across the arequal runs

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a distributed-stripe volume 3x2
2. add some data on the mount point and calculate arequal cheksum
3. Remove brick start on any one of the pair , once remove-brick completes commit it.
4. Now again calculate areequal checksum 
  
Actual results:
Checksum differs.

Expected results:


Additional info:

Client logs says [2012-05-21 19:52:22.155933] E [stripe-helpers.c:271:stripe_ctx_handle] 3-dis-stripe-stripe-2: Failed to get stripe-size
[2012-05-21 19:52:22.155962] E [stripe.c:212:stripe_lookup_cbk] 3-dis-stripe-stripe-2: Error getting fctx info from dict
[2012-05-21 19:52:22.156118] E [stripe-helpers.c:271:stripe_ctx_handle] 3-dis-stripe-stripe-2: Failed to get stripe-size
[2012-05-21 19:52:22.156141] E [stripe.c:212:stripe_lookup_cbk] 3-dis-stripe-stripe-2: Error getting fctx info from dict
[2012-05-21 19:52:22.158532] W [page.c:984:__ioc_page_error] 3-dis-stripe-io-cache: page error for page = 0x7f3ec8038fa0 & waitq = 0x7f3ec8034b70
[2012-05-21 19:52:22.158654] W [page.c:984:__ioc_page_error] 3-dis-stripe-io-cache: page error for page = 0x7f3ec8006f20 & waitq = 0x7f3ec801ac30
[2012-05-21 19:52:22.159257] E [stripe-helpers.c:271:stripe_ctx_handle] 3-dis-stripe-stripe-2: Failed to get stripe-size
[2012-05-21 19:52:22.159297] E [stripe.c:212:stripe_lookup_cbk] 3-dis-stripe-stripe-2: Error getting fctx info from dict
[2012-05-21 19:52:22.159508] E [stripe-helpers.c:271:stripe_ctx_handle] 3-dis-stripe-stripe-2: Failed to get stripe-size
[2012-05-21 19:52:22.159530] E [stripe.c:212:stripe_lookup_cbk] 3-dis-stripe-stripe-2: Error getting fctx info from dict
[2012-05-21 19:52:22.162160] W [page.c:984:__ioc_page_error] 3-dis-stripe-io-cache: page error for page = 0x7f3ec8038fa0 & waitq = 0x7f3ec8034b70

--- Additional comment from sgowda@redhat.com on 2012-08-08 10:43:55 EDT ---

Can we check if this issue still exists?
Comment 2 shylesh 2012-12-24 03:21:51 EST
Verified on the build 3.4.0qa5-1.el6rhs.x86_64
Comment 5 Scott Haines 2013-09-23 18:33:19 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.