Bug 854652 - Documentation is not generated properly during build
Summary: Documentation is not generated properly during build
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: grub
Version: 6.5
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Václav Pavlín
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-09-05 13:46 UTC by Ken Stailey
Modified: 2013-11-21 20:46 UTC (History)
3 users (show)

Fixed In Version: grub-0.97-82.el6
Doc Type: Bug Fix
Doc Text:
Cause: File grub.info was not cleaned on "make clean" command. Consequence: File grub.info was not generated with latest changes during build. Fix: Explicitly remove grub.info file and generate it during every build. Result: File grub.info now contains latest changes.
Clone Of:
Environment:
Last Closed: 2013-11-21 20:46:50 UTC


Attachments (Terms of Use)
Add --encryption in grub.info (1.81 KB, patch)
2013-04-05 08:05 UTC, Václav Pavlín
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1649 normal SHIPPED_LIVE grub bug fix and enhancement update 2013-11-21 00:40:10 UTC

Description Ken Stailey 2012-09-05 13:46:11 UTC
Description of problem:

The grub.conf file can include a "password" command which can use "--encrypted" as an option.  The documentation that comes in the grub RPM documents "password" but does not mention the "--encrypted" option.  With RHEL 5.* there was no such option, it is new with RHEL 6.*

Version-Release number of selected component (if applicable):

grub-0.97-77.el6.x86_64

How reproducible:

Always

Steps to Reproduce:

1. $ info -f grub.info -n password
  
Actual results:

Read the resulting text and see no mention of the --encrypted option.

Expected results:

Read the resulting text and see the --encrypted option mentioned.

Additional info:

If you want to see the --encrypted option try:

$ strings /boot/grub/stage2 | grep encrypted
--encrypted
password [--md5|--encrypted] PASSWD [FILE]
If used in the first section of a menu file, disable all interactive editing control (menu entry editor and command line). If the password PASSWD is entered, it loads the FILE as a new config file and restarts the GRUB Stage 2. If you omit the argument FILE, then GRUB just unlocks privileged instructions.  You can also use it in the script section, in which case it will ask for the password, before continueing. The option --md5 tells GRUB that PASSWD is encrypted with md5crypt, --encrypted that PASSWD is encrypted (with algorithm specified in PASSWD: supported is md5, sha-256, sha-512).

Comment 2 Václav Pavlín 2013-04-05 08:05:25 UTC
Created attachment 731849 [details]
Add --encryption in grub.info

Comment 3 RHEL Product and Program Management 2013-05-22 21:34:06 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 5 Ken Stailey 2013-08-02 12:25:30 UTC
Good catch!

Comment 7 Pavel Holica 2013-10-09 10:09:32 UTC
Reproduced on RHEL6.4 x86_64 Client.
Verified fix on RHEL6.5-20131004.5 x86_64 Client.

Comment 9 errata-xmlrpc 2013-11-21 20:46:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1649.html


Note You need to log in before you can comment on or make changes to this bug.