Bug 854689 - kernel-devel is including to autoconf.h files, one with 0 bytes
kernel-devel is including to autoconf.h files, one with 0 bytes
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 10:51 EDT by Brian J. Murrell
Modified: 2013-01-02 13:47 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-02 12:43:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian J. Murrell 2012-09-05 10:51:43 EDT
The kernel-devel package seems to include two autoconf.h files, one with content and one with 0 bytes:

$ rpm -qvlp kernel-devel-3.3.0-0.rc3.git5.1.fc17.x86_64.rpm | grep autoconf
-rw-r--r--    1 root    root                   826381 Feb 14  2012 /usr/src/kernels/3.3.0-0.rc3.git5.1.fc17.x86_64/include/generated/autoconf.h
-rw-r--r--    1 root    root                        0 Feb 14  2012 /usr/src/kernels/3.3.0-0.rc3.git5.1.fc17.x86_64/include/linux/autoconf.h

I wonder if this is intentional and if so, what the purpose is.
Comment 1 Josh Boyer 2012-09-05 11:26:48 EDT
This is probably coming from a section in the kernel.spec file that does:


    # Make sure the Makefile and version.h have a matching timestamp so that
    # external modules can be built
    touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
    touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h


That pre-dates our git usage and I'm not even sure it's needed any longer.
Comment 2 Josh Boyer 2013-01-02 12:43:26 EST
This was fixed in F18.
Comment 3 Brian J. Murrell 2013-01-02 12:48:30 EST
Cool.  How does it end up getting to EL?  It's needed there also.
Comment 4 Josh Boyer 2013-01-02 13:28:09 EST
(In reply to comment #3)
> Cool.  How does it end up getting to EL?  It's needed there also.

You will need to open a bug against the relevant RHEL release(s) to have it fixed in RHEL.  The Fedora and RHEL kernels are maintained separately.
Comment 5 Brian J. Murrell 2013-01-02 13:47:22 EST
~sigh~

To which I suppose I will get the standard "talk to your EL support sales person" boilerplate and since I don't have one of those, nothing will happen.

Note You need to log in before you can comment on or make changes to this bug.