Bug 854702 - Remove Column for *, Add * Directly to Quantity Cell When Relevant - All Available Subscriptions
Remove Column for *, Add * Directly to Quantity Cell When Relevant - All Avai...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Alex Wood
Entitlement Bugs
:
Depends On:
Blocks: 771481 840993 886216
  Show dependency treegraph
 
Reported: 2012-09-05 11:25 EDT by Matt Reid
Modified: 2013-02-21 03:56 EST (History)
4 users (show)

See Also:
Fixed In Version: subscription-manager-1.1.11-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:56:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
* Column merged with Quantity (53.02 KB, image/png)
2012-11-19 16:26 EST, Matt Reid
no flags Details
new quantity marker (68.56 KB, image/png)
2012-12-12 11:27 EST, J.C. Molet
no flags Details

  None (edit)
Description Matt Reid 2012-09-05 11:25:04 EDT
Description of problem:
In our current implementation of stacking, we have the text "* Click to Adjust Quantity". As far as I can tell, since the * lives in its own column, clicking it doesn't do anything, you click on the quantity cell to select the row (or wherever), and then once the row is selected, you can click on Quantity to get the spinner arrows to show up.

Until we have a better method, seems like we should eliminate the column for * and append the * directly within the Quantity cell in cases where they can adjust it. That way if they try to click on the *, as we tell them to, they can accomplish what they had hoped to.
Comment 1 Alex Wood 2012-11-19 16:14:54 EST
Matt,

Do you want something like this?

Old way:
| * | 100 |

New way:
| 100* |
Comment 2 Matt Reid 2012-11-19 16:26:05 EST
Created attachment 648130 [details]
* Column merged with Quantity

Sorry, looks like I forgot to attach this when I created the bug. 

I'd try it with a space in between the quantity and the *.
Comment 3 Alex Wood 2012-11-26 09:20:18 EST
commit f7b5e5c7acb00411bb85f63c7da835ea910c13ea
Author: Alex Wood <awood@redhat.com>
Date:   Tue Nov 20 16:12:06 2012 -0500

    854702: Place the asterisk indicating editability into the quantity cell.
Comment 4 Adrian Likins 2012-12-04 14:38:09 EST
in rhel-64


commit ba70614b5b730de5dfdc3d95937fb9f13a473f83
Author: Alex Wood <awood@redhat.com>
Date:   Tue Nov 20 16:12:06 2012 -0500

    854702: Place the asterisk indicating editability into the quantity cell.


should land in 1.1.11
Comment 6 J.C. Molet 2012-12-12 11:27:08 EST
Created attachment 662437 [details]
new quantity marker

Testing in subscription-manager-gui-1.1.11-1.el6.x86_64 (latest in rhel composes)

This appears to have been fixed in both the search list and the contract selection dialog.  It is now in the format "N *"  and appears to work exactly the same as it did before with no regressions so far according to automated test runs.

Marking VERIFIED.
Comment 8 errata-xmlrpc 2013-02-21 03:56:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.