Bug 854708 - EBUSY error when mapping FCoE target to iblock backend
EBUSY error when mapping FCoE target to iblock backend
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.3
Unspecified Linux
high Severity high
: rc
: 6.5
Assigned To: Andy Grover
Bruno Goncalves
:
: 896409 (view as bug list)
Depends On: 903297 1030730
Blocks: 896413
  Show dependency treegraph
 
Reported: 2012-09-05 11:54 EDT by Jason Mather
Modified: 2013-11-21 17:26 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 17:26:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to replace blkdev_put with close_bdev_exclusive (530 bytes, application/octet-stream)
2012-09-05 11:54 EDT, Jason Mather
no flags Details

  None (edit)
Description Jason Mather 2012-09-05 11:54:49 EDT
Created attachment 610088 [details]
Patch to replace blkdev_put with close_bdev_exclusive

Description of problem:  Second mapping of block device to iblock backend fails with EBUSY because device is still claimed after being unmapped.

The initial mapping uses open_bdev_exclusive, but the unmap call uses blkdev_put instead of the correct call which is close_bdev_exclusive.


Version-Release number of selected component (if applicable): 2.6.32-279.5.2


How reproducible: Always


Steps to Reproduce:
1.  Create an iblock virtual device on a block device
2.  Delete the iblock virtual device
3.  Create the iblock virtual device again.
  
Actual results:
Fails with Device or resource busy

Expected results:
Succeeds

Additional info:
Patch attached.
Comment 2 Jason Mather 2012-09-14 09:47:38 EDT
This bug is not present in the upstream kernel.  It was introduced when the target code was backported which is why I'm reporting it here.
Comment 4 RHEL Product and Program Management 2012-12-14 03:52:37 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Andy Grover 2013-02-26 19:35:26 EST
*** Bug 896409 has been marked as a duplicate of this bug. ***
Comment 6 RHEL Product and Program Management 2013-04-11 22:26:45 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 7 Bruno Goncalves 2013-08-07 06:41:26 EDT
Reproduced error on kernel-2.6.32-387.el6.x86_64

Fixed on kernel-2.6.32-407.el6.x86_64
Comment 9 Marcus Koontz 2013-10-23 18:08:13 EDT
Verified by Intel:
Reproduced error on kernel-2.6.32-358.18.1.el6.x86_64

Verified fixed in kernel-2.6.32-421.el6.x86_64
Comment 10 errata-xmlrpc 2013-11-21 17:26:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1683.html

Note You need to log in before you can comment on or make changes to this bug.