Bug 854722 - autologin doesn't work for liveuser on desktop live spin
autologin doesn't work for liveuser on desktop live spin
Status: CLOSED DUPLICATE of bug 882037
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
AcceptedNTH https://fedoraproject.org...
: CommonBugs
Depends On:
Blocks: F18-accepted/F18FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2012-09-05 12:24 EDT by Kamil Páral
Modified: 2013-02-13 11:41 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 11:41:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs when it fails to auto-login (10.00 KB, application/x-bzip)
2013-02-13 10:15 EST, Richard Hughes
no flags Details
logs with the LSB header (20.00 KB, application/x-bzip)
2013-02-13 11:32 EST, Richard Hughes
no flags Details

  None (edit)
Description Kamil Páral 2012-09-05 12:24:38 EDT
Description of problem:
Autologin doesn't work in GDM on LiveCD, you have to click on liveuser account. That is not desired. Something is broken.

Version-Release number of selected component (if applicable):
Fedora 18 Alpha TC5 Live GNOME

How reproducible:
always
Comment 1 Kamil Páral 2012-09-05 12:27:21 EDT
Proposing as F18 blocker or NTH.
Comment 2 Ray Strode [halfline] 2012-09-06 13:43:45 EDT
fwiw, it works on the nightly i got (though I have to boot with " 3 " on the kernel command line update xorg-x11-drv-qxl from updates-testing and init 5 to test because of the qxl bug
Comment 3 Petr Schindler 2012-09-13 08:42:36 EDT
This is still present in Alpha RC3. /etc/gdm/custom.conf seems to be all right. I tried the same configuration on the installed system and autologin works fine.

/etc/gdm/custom.conf:
# GDM configuration storage

[daemon]

[security]

[xdmcp]

[greeter]

[chooser]

[debug]

[daemon]
AutomaticLoginEnable=True
AutomaticLogin=liveuser
Comment 4 Ray Strode [halfline] 2012-09-14 16:27:10 EDT
oh i fixed this upstream:

http://git.gnome.org/browse/gdm/commit/?id=aafa4070f2905c4848091a78422210951775cd9a

turns out its sort of random whether it will work or not depending on how fast the system is etc.
Comment 5 Matthias Clasen 2012-09-26 18:40:09 EDT
Fix is included in current packages in updates-testing
Comment 6 Adam Williamson 2012-12-12 14:44:20 EST
Discussed at 2012-12-12 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-12/f18final-blocker-review-4.2012-12-12-17.01.log.txt . Accepted as NTH - autologin is intended behaviour and would be better polish, can't be fixed with an update.

This is broken in Final TC1, with a gdm way later than September, so setting back to assigned. Live boot reliably shows GDM with 'liveuser' account, for me, I don't recall autologin ever working in any F18 test for me. Kparal says the same.
Comment 7 Matthew Miller 2012-12-12 15:41:45 EST
Autologin has worked for me, as recently as last week. However, I've turned it off, because of bug #881896.
Comment 8 Kamil Páral 2012-12-13 07:02:54 EST
Matthew, we're talking about autologin on LiveCD. For some reason that doesn't work. Autologin on an installed system works, yes.
Comment 9 Adam Williamson 2012-12-13 13:39:29 EST
clarify summary.
Comment 10 Richard Hughes 2013-02-13 05:28:08 EST
(In reply to comment #5)
> Fix is included in current packages in updates-testing

I've tried re-spinning a LiveCD with F18+updates (gdm-3.6.2-5.fc18) but that failed to auto-login too.
Comment 11 Richard Hughes 2013-02-13 10:15:46 EST
Created attachment 696837 [details]
logs when it fails to auto-login
Comment 12 Ray Strode [halfline] 2013-02-13 10:41:09 EST
hughsie found me on irc and we debugged a bit. it's looking like the problem is caused by duplicate sections in the config file (which isn't allowed).

He's going to confirm, and if that checks out, we'll probably just push a fix to spin-kickstarts.git and close the bug.
Comment 13 Ray Strode [halfline] 2013-02-13 11:19:37 EST
so there's seemingly more to the story.  We think now the problem is the livecd init script is getting started in parallel with gdm, but the livecd user isn't created until the init script finishes.

hughsie is doing a spin with LSB headers at the top of the initscript to enforce ordering with GDM to see if that helps.
Comment 14 Richard Hughes 2013-02-13 11:32:43 EST
Created attachment 696906 [details]
logs with the LSB header

This is with debugging enabled and this at the head of livesys:

#!/bin/bash
#
# live: Init script for live image
#
# chkconfig: 345 00 99
# description: Init script for live image.
### BEGIN INIT INFO
# X-Start-Before: gdm.service
### END INIT INFO
Comment 15 Ray Strode [halfline] 2013-02-13 11:41:11 EST
heh i knew this was deja vu.  let's move to the other bug.

*** This bug has been marked as a duplicate of bug 882037 ***

Note You need to log in before you can comment on or make changes to this bug.