This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 854753 - Hadoop Integration, Address known write performance issues
Hadoop Integration, Address known write performance issues
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: gluster-hadoop (Show other bugs)
mainline
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Diane Feddema
hcfs-gluster-bugs
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 14:27 EDT by Kaleb KEITHLEY
Modified: 2015-04-07 05:16 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-07 05:16:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaleb KEITHLEY 2012-09-05 14:27:21 EDT
Description of problem:

Blocker BZ for RHS 2.1

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 4 Steve Watt 2013-05-10 13:50:05 EDT
Assigning to Diane to analyze write performance. The current observation is that because of the glusterfs use of the elastic hashing algorithm, writes get written to the server that will hosts the data according the hash. In some cases, this results in non-local writes.
Comment 6 Kaleb KEITHLEY 2015-04-07 05:16:22 EDT
This was opened to track a concern raised by Doug Williams which ultimately turned out to be a red herring.

Closing as it's old and there doesn't seem to be any real issue. Please open a new BZ if this is not the case.

Thanks,

Note You need to log in before you can comment on or make changes to this bug.