Bug 854772 - publican builds fail silently
publican builds fail silently
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 19:31 EDT by Joshua Wulf
Modified: 2014-10-19 19:01 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.26.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-06 21:30:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-09-05 19:31:31 EDT
No error message reported when using csprocessor assemble:

Content Specification build unzipped to /home/sitapati/Ubuntu One/books/Messaging_Programming_Reference/assembly/publican
Starting the publican build...
sitapati@ubuntu:~/Ubuntu One/books/Messaging_Programming_Reference$ 

and an exit code of 255:
$ echo $?
255

However, manually running publican reveals an error condition:
$ publican build --formats=en-US --langs=en-US
Failed to load brand file: /usr/share/publican/Common_Content/redhat-video/publican.cfg at /usr/bin/publican line 647

and an exit code of 2 from publican:
$ echo $?
2


Does an exit code of 255 from csprocessor signify a specific error condition?

Is it possible to propagate the publican error message or error condition, or at least report that publican exited with an error?

==============================
Generated Details:

CSProcessor client version: 0.26.5


OS: unknown
JAVA: java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11.4) (6b24-1.11.4-1ubuntu0.12.04.1)
OpenJDK Client VM (build 20.0-b12, mixed mode, sharing)
Comment 1 Lee Newson 2012-09-09 23:49:35 EDT
Fixed in 0.26.7

This fix consists of two parts.

The first is to fix the output so that it is printed to the screen. This was caused by a timing issue when using threads to display the output. I've added checks in to ensure that the output is always printed before destroying the threads and moving on.

The second is to report the error code from publican in some form. Since there is overlap between the existing error codes and publican I've gone with adding the error code to the output (after the errors printed by publican). eg new error message:

Unable to assemble the Content Specification because an error occured while running Publican. (exit code 12)
Comment 2 Lee Newson 2013-06-06 21:30:11 EDT
Closing and setting as current release as no QA was performed by the original reporter. If there is still an issue with this bug still than please re-open it.

Note You need to log in before you can comment on or make changes to this bug.