Bug 854807 - Starting/Stopping AS instance doesn't immediately change availability status in UI
Starting/Stopping AS instance doesn't immediately change availability status ...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: No Component (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: 854805
  Show dependency treegraph
 
Reported: 2012-09-05 23:02 EDT by Charles Crouch
Modified: 2015-02-01 18:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-09 02:00:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 47875 None None None 2012-09-05 23:05:04 EDT

  None (edit)
Description Charles Crouch 2012-09-05 23:02:40 EDT
Users typically have the expectation that availability checks will reflect AS servers going up or down IMMEDIATELY. Given that is not the case, we should think about how to indicate to the user that we are polling for avail and are not event driven, e.g. next to the Resource's availability badge we have a label saying:

    Polling every: <X>
    where <X> is taken from the availability schedule.

Another option which I believe we may have already investigated is triggering an availability scan as part of an operation. However I do not expect this will provide the IMMEDIATE feedback users expect, i.e. as soon as the start or stop operation has executed that the availability icon will be updated to match appropriately. However I don't view this as sufficient since this requires updates to any plugin to take advantage of this feature and also doesn't address out-of-band changes, e.g. someone stopping an AS instance via the terminal versus through JON.
Comment 1 Heiko W. Rupp 2013-12-09 02:00:57 EST
The new live avail feature in RHQ 4.9 should solve this issue.

Note You need to log in before you can comment on or make changes to this bug.