Bug 854873 - python-django-tagging does not Obsolete / Provide django-tagging
python-django-tagging does not Obsolete / Provide django-tagging
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-django-tagging (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Runge
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-06 04:13 EDT by Hans de Goede
Modified: 2012-09-17 18:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 18:23:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2012-09-06 04:13:59 EDT
While running package-cleanup --orphans on my F-18 install it said django-tagging was an orphan, according to: http://pkgs.fedoraproject.org/cgit/django-tagging.git/tree/dead.package  this is because it was renamed to python-django-tagging.

But renamed packages MUST Obsolete and Provide their old name, so that upgrading works properly, an other form of the same problem is:

sudo yum install python-django-tagging

...

Transaction Check Error:
  file /usr/lib/python2.7/site-packages/django_tagging-0.3.1-py2.7.egg-info from install of python-django-tagging-0.3.1-5.fc18.noarch conflicts with file from package django-tagging-0.3.1-3.fc17.noarch


So the spec file should have the following lines added:

Obsoletes: django-tagging < %{version}-%{release}
Provides: django-tagging = %{version}-%{release}


Note the same goes for any other renamed django packages!
Comment 1 Hans de Goede 2012-09-06 04:21:20 EDT
Hi,

After manual upgrading I see the problem is not a missing obsoletes but a wrong obsoletes:

[hans@shalem f17]$ rpm -q --obsoletes python-django-tagging
django-tagging < 0.3.1-3

But F-17 has:
django-tagging-0.3.1-3.fc17.noarch

So the Obsoletes should be:
django-tagging <= 0.3.1-3

Regards,

Hans
Comment 2 Matthias Runge 2012-09-06 04:37:05 EDT
Hans, thank you for the report, you're absolutely right!

I'm pushing a fix in a couple of minutes.
Comment 3 Fedora Update System 2012-09-06 04:53:33 EDT
python-django-tagging-0.3.1-6.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-django-tagging-0.3.1-6.fc18
Comment 4 Fedora Update System 2012-09-07 15:39:52 EDT
Package python-django-tagging-0.3.1-6.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-django-tagging-0.3.1-6.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13580/python-django-tagging-0.3.1-6.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-09-17 18:23:06 EDT
python-django-tagging-0.3.1-6.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.