Bug 854881 - Improvement suggestions for all F18 test candidates
Improvement suggestions for all F18 test candidates
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-06 04:31 EDT by Joachim Backes
Modified: 2012-11-22 20:32 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 20:32:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2012-09-06 04:31:30 EDT
Description of problem:
some general issues concerning anaconda of all F18 test candidates:

1. Selecting the different options seems not to be
   comprehensible for Fedora newcomers: Why to press "back" for
   selecting the next options (for example, after have done the keyboard
   selection I want to select the time zone).
   Additionally, it can take some time until the yellow triangle
   disappers after having selected an option. This has to be clarified
   for users. They could think that the option has not be accepted
   Why is there no "next option" button for the selection of the next
   option, insensitive until the option has been accepted?
   It could be that the "back" button means for a lot of users:
   "forget my previous settings and redo them".

2. There are some high hurdles for choosing an own partitioning scheme
   for the disks the machine has to use. I miss a simple dialogue
   based function for changing the disk's layout. The given ±
   buttons are not directly understandable.
   Alternatively, Or some explanatory text could help newcomers.

Version-Release number of selected component (if applicable):

F18 anaconda

How reproducible:

--
Steps to Reproduce:
1.Try to install F18 with the test candidates
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Joachim Backes 2012-09-06 05:57:37 EDT
A third point: It is very difficult to edit the installed grub menu if booting the installed machine. I think the methods offered in F17 and previous were better to handle, but I don't know if the new layout is a grub2 feature or a fedora feature.

Summa summarum: one should think about a better editable grub menu.
Comment 2 Martin Sivák 2012-09-06 12:27:16 EDT
Please fill all those points as separate bugs. We can track only one issue in one bug.
Comment 3 Chris Lumens 2012-09-06 14:44:05 EDT
> 1. Selecting the different options seems not to be
>    comprehensible for Fedora newcomers: Why to press "back" for
>    selecting the next options (for example, after have done the keyboard
>    selection I want to select the time zone).

I think the wording of this button could use a little work.

>    Additionally, it can take some time until the yellow triangle
>    disappers after having selected an option. This has to be clarified
>    for users. They could think that the option has not be accepted

The italicized text underneath the title of the spoke selector tells you what is happening.

>    Why is there no "next option" button for the selection of the next
>    option, insensitive until the option has been accepted?
>    It could be that the "back" button means for a lot of users:
>    "forget my previous settings and redo them".

There is no Next button because that's not how the UI is laid out, and the concept of Next doesn't mean anything anymore.  We aren't giving you a strict order you must follow.  We are giving you all the things you could possibly do, and you can work your way through them in whatever order you'd like.

> 2. There are some high hurdles for choosing an own partitioning scheme
>    for the disks the machine has to use. I miss a simple dialogue
>    based function for changing the disk's layout. The given ±
>    buttons are not directly understandable.
>    Alternatively, Or some explanatory text could help newcomers.

First, you're in the custom partitioning interface so some level of expertise has to be assumed.  Second, I think part of the confusion here is that our new custom partitioning interface approaches things completely differently.  We are providing a top-down interface here where you decide what your end goal is (the mount point), and then we build the things that make it up from there.

If you look at everything on that screen, it's all mount point based.  The left side lists mount points.  Thus the +/- buttons should be assumed to operate based on mount points.
Comment 4 Joachim Backes 2012-09-07 02:11:42 EDT
(In reply to comment #2)
> Please fill all those points as separate bugs. We can track only one issue
> in one bug.

I think comment #3 answers almost all my questions, so I will not open new bugs.
Only one thing: I'm sure the users need a lot of papers including instructions how to install F18 (because of these drastic changes!).

Kind regards

Joachim Backes
Comment 5 Adam Williamson 2012-09-15 02:09:09 EDT
Chris: "The italicized text underneath the title of the spoke selector tells you what is happening."

note that this text is virtually invisible in some desktops, especially KDE. That might be why people aren't noticing it. You should probably try running newui in each desktop to see what I mean, at least try KDE.
Comment 6 Chris Lumens 2012-09-24 15:41:09 EDT
Yeah, fixed that up last week after checking out the KDE live image.  In light of that and rewording some of the buttons, I'm going to put this into MODIFIED for now.  Hopefully I didn't miss anything.
Comment 7 Adam Williamson 2012-09-24 17:37:21 EDT
Is the change in 18.8? If it is I can spin up some lives and test, if not I'll wait for the next build.
Comment 8 Adam Williamson 2012-11-22 20:32:34 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

(for many builds now, the buttons say Done not Back, and the italicized text is legible on all desktops).

Note You need to log in before you can comment on or make changes to this bug.