Bug 854888 - [SetupNetworks] Can attach VLAN network with custom MTU with NON_VM network on the same nic/BOND
[SetupNetworks] Can attach VLAN network with custom MTU with NON_VM network ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: lpeer
Meni Yakove
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-06 04:44 EDT by Meni Yakove
Modified: 2016-02-10 14:51 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-09 08:23:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (6.90 MB, text/x-log)
2012-09-06 04:44 EDT, Meni Yakove
no flags Details

  None (edit)
Description Meni Yakove 2012-09-06 04:44:05 EDT
Created attachment 610226 [details]
engine.log

Description of problem:
UI allow to attach VLAN network with custom MTU to nic/BOND that already have NON_VM network with custom MTU.
For any non VLAN network this operation blocked by UI.

Version-Release number of selected component (if applicable):
rhevm-3.1.0-15.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1.Create two networks, NON_VM_MTU_5000 and VM_VLAN_MTU_9000
2.Assign both networks to nic  

  
Actual results:
Should be blocked by UI

Expected results:
UI allow to attach both networks.
Comment 1 lpeer 2012-09-09 02:32:38 EDT
1. In which version did you find the bug? (please make sure to always specify that when you report a bug)
2. Is it blocked by the backend?
Comment 2 Meni Yakove 2012-09-09 07:27:14 EDT
1. Version-Release number of selected component (if applicable):
rhevm-3.1.0-15.el6ev.noarch
2. It is blocked by the backend.

If the decision is not to block the operation on the UI so this BUG should be closed.
Comment 3 lpeer 2012-09-09 08:23:21 EDT
At this point we have decided not to block any MTU related issue in the UI.
Adding the validation code for MTU makes the logic in the UI more complicated.

Since this operation is blocked in the engine, we'll avoid adding this logic in the UI for the time being.

Note You need to log in before you can comment on or make changes to this bug.