Bug 854957 - SELinux is preventing /usr/lib/cups/backend/mfp from 'read' accesses on the file /usr/share/cups/model/samsung/cms/CLX-3160-600x600cms2.
SELinux is preventing /usr/lib/cups/backend/mfp from 'read' accesses on the f...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:0104ed7dafe4c762442d057ed08...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-06 07:41 EDT by Sona Pochybova
Modified: 2012-09-06 08:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-06 08:12:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sona Pochybova 2012-09-06 07:41:08 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.9-2.fc16.x86_64
time:           Thu 06 Sep 2012 12:27:33 PM CEST

description:
:SELinux is preventing /usr/lib/cups/backend/mfp from 'read' accesses on the file /usr/share/cups/model/samsung/cms/CLX-3160-600x600cms2.
:
:*****  Plugin restorecon (99.5 confidence) suggests  *************************
:
:If you want to fix the label. 
:/usr/share/cups/model/samsung/cms/CLX-3160-600x600cms2 default label should be lib_t.
:Then you can run restorecon.
:Do
:# /sbin/restorecon -v /usr/share/cups/model/samsung/cms/CLX-3160-600x600cms2
:
:*****  Plugin catchall (1.49 confidence) suggests  ***************************
:
:If you believe that mfp should be allowed read access on the CLX-3160-600x600cms2 file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep mfp /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:cupsd_t:s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:user_home_t:s0
:Target Objects                /usr/share/cups/model/samsung/cms/CLX-3160-600x600
:                              cms2 [ file ]
:Source                        mfp
:Source Path                   /usr/lib/cups/backend/mfp
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           cups-1.5.2-9.fc16.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-91.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.4.9-2.fc16.x86_64 #1 SMP
:                              Thu Aug 23 17:51:29 UTC 2012 x86_64 x86_64
:Alert Count                   24
:First Seen                    Thu 06 Sep 2012 12:20:17 PM CEST
:Last Seen                     Thu 06 Sep 2012 12:22:40 PM CEST
:Local ID                      a504c7f1-e93b-4ed8-bf2b-898300107206
:
:Raw Audit Messages
:type=AVC msg=audit(1346926960.15:279): avc:  denied  { read } for  pid=6318 comm="cups-driverd" name="CLX-3160-600x600cms2" dev="dm-1" ino=667192 scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1346926960.15:279): arch=x86_64 syscall=open success=no exit=EACCES a0=7fff83a73d90 a1=0 a2=0 a3=7fff83a72450 items=0 ppid=5071 pid=6318 auid=4294967295 uid=4 gid=7 euid=4 suid=4 fsuid=4 egid=7 sgid=7 fsgid=7 tty=(none) ses=4294967295 comm=cups-driverd exe=/usr/lib/cups/daemon/cups-driverd subj=system_u:system_r:cupsd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: mfp,cupsd_t,user_home_t,file,read
:
:audit2allow
:
:#============= cupsd_t ==============
:allow cupsd_t user_home_t:file read;
:
:audit2allow -R
:
:#============= cupsd_t ==============
:allow cupsd_t user_home_t:file read;
:
Comment 1 Miroslav Grepl 2012-09-06 08:12:47 EDT
The problem is you moved this file from your homedir. You need to fix labeling in this case using

# restorecon -v /usr/share/cups/model/samsung/cms/CLX-3160-600x600cms2


Also the alert tells you what to do.

Note You need to log in before you can comment on or make changes to this bug.