This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 855000 - [FJ-SAM Bug]: Can auto-subscribe even when "auto-subscribe" is turned off in SAM WebUI
[FJ-SAM Bug]: Can auto-subscribe even when "auto-subscribe" is turned off in ...
Status: CLOSED DUPLICATE of bug 854800
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.0
All Linux
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Tom McKay
Katello QA List
: OtherQA
Depends On: 854800
Blocks: 804059 sam12-tracker
  Show dependency treegraph
 
Reported: 2012-09-06 09:37 EDT by Eric Sammons
Modified: 2013-08-14 16:28 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 854800
Environment:
Last Closed: 2012-09-21 08:33:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Sammons 2012-09-06 09:37:30 EDT
+++ This bug was initially created as a clone of Bug #854800 +++

Created attachment 610149 [details]
sosreport of SAM server

Customer Contact Name:
  Masahiro Imada
  
Description of Problem:
 On SAM WebUI, we have turned off auto-subscribe function for the system registered. However, the system registered to SAM can still auto-subscribe by following command.

  # subscription-manager subscribe --auto

 Please fix SAM so that we can turn off auto-subscribe.
 
Version-Release number of selected component:

  Red Hat Enterprise Linux Version Number: 6
  Release Number: 6.3
  Architecture: Intel64
  Kernel Version: 2.6.32-279.el6
  Related Package Version: 
    katello-glue-candlepin-0.3.3-1.el6_2.noarch
    katello-headpin-all-0.2.13-1.el6_2.noarch
    katello-common-0.3.3-1.el6_2.noarch
    katello-configure-0.3.7-1.el6_2.noarch
    katello-headpin-0.2.13-1.el6_2.noarch
    katello-candlepin-cert-key-pair-1.0-1.noarch
    katello-cli-common-0.3.5-2.el6_2.noarch
    katello-certs-tools-1.1.5-1.el6_2.noarch
    katello-selinux-0.2.4-1.el6_2.noarch
    katello-cli-headpin-0.2.2-1.el6_2.noarch
  
  Related Middleware/Application: None

Drivers or hardware or architecture dependency: 
  None

How reproducible: 
  Always

Step to Reproduce:
  [1]Build a SAM server.
  [2]Register a system to SAM.
  [3]Turn off "auto-subscribe" of the registered system through SAM WebUI.
  [4]Execute "subscription-manager subscribe --auto" on the registered client.
	
Actual Results:
  The registered system can still auto-subscribe even after it is turned off.

Expected Results:
  The registered system cannot auto-subscribe after it is turned off.

Summary of actions taken to resolve issue:
  None
 
Location of diagnostic data:
  None
 
Hardware configuration:
  Hypervisor: KVM
  Model: PRIMERGY RX200 S5
  CPU Info: Intel(R) Xeon(R) CPU X5570 @ 2.93GHz
  Memory Info: 8GB
  Hardware Component Information:
  Configuration Info:
  Guest Configuration Info:

Business Impact:
If it's impossible to stop auto-subscribe on SAM WebUI, our customers cannot prevent easily RHEL users from subscribing unexpected subscriptions they don't want to use. Thus, the customers will take much time to instruct the users not to use auto-subscribe.

  Target Release: Subscriptions Asset Manager 1.2

  Errata Request:

Additional Info:
  We attached the sosreport of the SAM server and the registered system.

--- Additional comment from moshiro@redhat.com on 2012-09-05 23:47:09 EDT ---

Hi Fujitsu,

I will monitor this ticket as a TAM.

Best Regards,
Moritoshi Oshiro
Comment 2 Tom McKay 2012-09-21 08:33:49 EDT
Mistaken clone

*** This bug has been marked as a duplicate of bug 854800 ***

Note You need to log in before you can comment on or make changes to this bug.