Bug 855011 - rhn-channel incorrect password error is very poorly worded
rhn-channel incorrect password error is very poorly worded
Status: CLOSED DUPLICATE of bug 846359
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
6.5
Unspecified Linux
unspecified Severity low
: rc
: ---
Assigned To: Milan Zazrivec
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-06 10:03 EDT by Jeff Needle
Modified: 2012-09-06 10:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-06 10:18:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Needle 2012-09-06 10:03:09 EDT
# rhn-channel -u something -p wrongpassword -r -c somechannel
An error has occurred:
<type 'exceptions.TypeError'>
See /var/log/up2date for more information

and in /var/log/up2date:

[Thu Sep  6 10:00:39 2012] up2date
Traceback (most recent call last):
  File "/usr/sbin/rhn-channel", line 164, in <module>
    systemExit(1, e)
  File "/usr/sbin/rhn-channel", line 46, in systemExit
    sys.stderr.write(rhncli.utf8_encode(msg)+'\n')
<type 'exceptions.TypeError'>: unsupported operand type(s) for +: 'AuthenticationOrAccountCreationError' and 'str'

Wouldn't something like "Hey pinhead, you typed the wrong password!" after the command line be a bit more informative?
Comment 2 Milan Zazrivec 2012-09-06 10:18:51 EDT
The error message suggested in the initial comment sounds cute, but I'm
gonna go with the fix from bug #846359 (or #804559 if you will) :-)

*** This bug has been marked as a duplicate of bug 846359 ***

Note You need to log in before you can comment on or make changes to this bug.