Bug 855050 - Update Icon Paths in Dialog Windows - Replace Generic Icons with RHSM Icon
Update Icon Paths in Dialog Windows - Replace Generic Icons with RHSM Icon
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.11
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
:
Depends On:
Blocks: rhsm-rhel511
  Show dependency treegraph
 
Reported: 2012-09-06 10:58 EDT by Matt Reid
Modified: 2014-09-15 20:21 EDT (History)
5 users (show)

See Also:
Fixed In Version: subscription-manager-1.1.4-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-15 20:21:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Generic Icon (9.62 KB, image/png)
2012-09-06 11:02 EDT, Matt Reid
no flags Details
Proper Icon (3.78 KB, image/png)
2012-09-06 11:03 EDT, Matt Reid
no flags Details
still showing generic icon in the date picker dialog decoration (53.36 KB, image/png)
2012-12-07 18:21 EST, John Sefler
no flags Details
FailedQA (903.04 KB, image/png)
2013-09-20 13:55 EDT, John Sefler
no flags Details
screenshots showing subscription-manager-gui dialogs with the expected icons circled (514.64 KB, image/png)
2014-06-23 17:34 EDT, John Sefler
no flags Details

  None (edit)
Description Matt Reid 2012-09-06 10:58:01 EDT
Description of problem:
We were still missing it for some dialogs, but when we switched over to using the proper PNGs instead of the SVG, we lost some of the progress we had made on eliminating the generic icon from being used in our dialogs.

Dialogs I've seen in the newer builds that are using the generic window icon:
About
License
Import Cert
System Facts
Proxy Config
System Preferences
Unregister Confirmation
Unsubscribe Confirmation
System Registration
No action needed dialog (when green and try to auto-sub)
Must manually subscribe dialog (cases where auto-sub fails)

That might not be everything, maybe there's an easy way to double-check in the code? Should be most of them at least.

If it helps to see an implemented example, the Filters and Searching (Update button) dialogs use the right icon.

Version -
1.0.17-1.git.0.279356f
Comment 1 Matt Reid 2012-09-06 11:02:50 EDT
Created attachment 610384 [details]
Generic Icon
Comment 2 Matt Reid 2012-09-06 11:03:16 EDT
Created attachment 610385 [details]
Proper Icon
Comment 3 Matt Reid 2012-10-01 15:05:42 EDT
The Subscription Redemption dialog also needs the proper icon.
Comment 4 Bryan Kearney 2012-10-30 15:14:42 EDT
fixed in master at 3f3ebfd2c6c9fcdb08e8cab6b99ed7cfbba00f49
Comment 6 Adrian Likins 2012-11-08 17:48:33 EST
commit 3f3ebfd2c6c9fcdb08e8cab6b99ed7cfbba00f49
Author: Bryan Kearney <bkearney@redhat.com>
Date:   Tue Oct 30 14:35:32 2012 -0400

    855050: Set the icon-name property on all dialogs and windows
Comment 8 Matt Reid 2012-11-12 13:43:47 EST
I still see the generic icon on:
Date Picker from All Available Subs tab
License Info from the About dialog

This was with subscription-manager-1.1.1.5-1.git.14.ae9fffd.

Looks like almost all of the generic icons are gone now!

If we go back and fix the License dialog icon as part of this bz, we can close out https://bugzilla.redhat.com/show_bug.cgi?id=839318
Comment 9 John Sefler 2012-12-07 18:21:50 EST
Created attachment 659646 [details]
still showing generic icon in the date picker dialog decoration

[root@jsefler-6 ~]# rpm -q subscription-manager-gui
subscription-manager-gui-1.1.11-1.el6.x86_64

Moving status back to ASSIGNED/FailedQA
Comment 12 Bryan Kearney 2013-09-03 14:19:07 EDT
this is in 1.9.2
Comment 13 John Sefler 2013-09-20 13:55:39 EDT
Created attachment 800594 [details]
FailedQA

[root@jsefler-6 ~]# rpm -q subscription-manager-gui
subscription-manager-gui-1.9.6-1.el6.x86_64
Comment 15 Devan Goodwin 2014-01-30 08:43:38 EST
These icons are not even visible in RHEL 7 due to the changes in GTK.

Deferring to RHEL 6.6 where they can actually be seen. Removing RHEL 7 acks.
Comment 18 RHEL Product and Program Management 2014-05-28 12:49:10 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 19 Carter Kozak 2014-05-30 13:38:15 EDT
commit 1e52e8745eeee76103e7dbe5779752287514b59c
Author: ckozak <ckozak@redhat.com>
Date:   Wed May 28 12:29:36 2014 -0400

    855050: set default fallback window icon
Comment 20 John Sefler 2014-06-23 17:34:03 EDT
Created attachment 911594 [details]
screenshots showing subscription-manager-gui dialogs with the expected icons circled

Verifying Version...
[root@jsefler-5 ~]# rpm -q subscription-manager-gui
subscription-manager-gui-1.11.3-6.el5
Comment 23 errata-xmlrpc 2014-09-15 20:21:57 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1225.html

Note You need to log in before you can comment on or make changes to this bug.