Bug 855059 - RFE: virt-p2v: display more information about network devices such as topology, bonding, etc.
RFE: virt-p2v: display more information about network devices such as topolog...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
P2V
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-06 11:23 EDT by joherr
Modified: 2015-11-19 01:56 EST (History)
10 users (show)

See Also:
Fixed In Version: libguestfs-1.28.1-1.36.el7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 01:56:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
New "Network interfaces" dialog (13.39 KB, image/png)
2015-05-14 09:05 EDT, Richard W.M. Jones
no flags Details

  None (edit)
Description joherr 2012-09-06 11:23:13 EDT
Is it possible to display more information about the network devices such as which devices are bonded together or part of a bridge.

This would allow the user to more easily select the interfaces for conversion.
Comment 2 RHEL Product and Program Management 2012-12-14 03:18:49 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Richard W.M. Jones 2015-05-14 09:05:00 EDT
Created attachment 1025393 [details]
New "Network interfaces" dialog

I don't believe it's possible to display information about bonding
because that would require knowledge from the operating system that
is being converted, which virt-p2v does not have access to.

However, I can display more useful information about the network
interface, including the MAC address and the Vendor, which should
make identifying them a bit easier.

I have modified the Network interface dialog to display this extra
information, and the result is shown in the attached screenshot.

Patch commited upstream:

https://github.com/libguestfs/libguestfs/commit/0833c192b68e87bb10fecf8352a355474c3915bf
Comment 5 Richard W.M. Jones 2015-05-20 06:37:48 EDT
Please PM ACK this.  The bug has been fixed already.
Comment 6 Richard W.M. Jones 2015-05-20 06:51:40 EDT
Sorry, wrong NEEDINFO.  Siddharth, please PM ACK this.
Comment 7 tingting zheng 2015-05-31 23:19:05 EDT
Tested with:
libguestfs-1.28.1-1.37.el7.x86_64
virt-v2v-1.28.1-1.37.el7.x86_64
livecd-p2v-201505191242.iso	

After launch virt-p2v from virt-p2v iso,there is detailed info shows under "Network Interfaces" as the screenshot shows in comment 4.
Comment 9 tingting zheng 2015-07-27 22:44:19 EDT
Refer to comment 7,move this bug to VERIFIED.
Comment 11 errata-xmlrpc 2015-11-19 01:56:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2183.html

Note You need to log in before you can comment on or make changes to this bug.