Bug 855067 - ettercap should probably obsolete ettercap-gtk and ettercap-common
ettercap should probably obsolete ettercap-gtk and ettercap-common
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ettercap (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-06 11:35 EDT by Bruno Wolff III
Modified: 2012-09-18 23:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 20:01:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2012-09-06 11:35:51 EDT
Description of problem:
When upgrading from 0.7.4.1-4.fc18 to 0.7.5-0.fc18, the upgrade will fail if ettercap-gtk is installed since ettercap-gtk-0.7.4.1-4.fc18 and ettercap-common-0.7.4.1-4.fc18 have file conflicts with ettercap-0.7.5-0.fc18.

Version-Release number of selected component (if applicable):
0.7.5-0.fc18

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Gwyn Ciesla 2012-09-06 11:41:54 EDT
It does.  From spec:

Obsoletes: ettercap-plugins < 0.7.3-15
Provides: ettercap-plugins = %{version}-%{release}
Obsoletes: ettercap-common < 0.7.4.1-4
Provides: ettercap-common = %{version}-%{release}
Obsoletes: ettercap-gtk < 0.7.4.1-4
Provides: ettercap-gtk = %{version}-%{release}
Comment 2 Bruno Wolff III 2012-09-06 11:59:15 EDT
Ah, it looks like the version tested against is wrong. 0.7.4.1-4 made it to at least updates-testing in f18. So the test should probably be against 0.7.4.1-5 or even 0.7.5.
Comment 3 Gwyn Ciesla 2012-09-06 12:08:44 EDT
Ah, I see, I should have used <=, not <, I'll just do < 0.7.5.  Thanks!
Comment 4 Bruno Wolff III 2012-09-06 12:14:18 EDT
Note for future reference, you need to be careful with <=. You need to include the fedora version since .fcXX is part of the release name. It's usually safer/easier to use < .
Comment 5 Gwyn Ciesla 2012-09-06 12:17:29 EDT
Right, I wasn't necessarily thinking < was better, just that I saw < and had <= in my head, and expressed that poorly.
Comment 6 Fedora Update System 2012-09-06 12:28:30 EDT
ettercap-0.7.5-0.fc18.20120906gitc796e5 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ettercap-0.7.5-0.fc18.20120906gitc796e5
Comment 7 Fedora Update System 2012-09-06 12:30:37 EDT
ettercap-0.7.5-0.fc17.20120906gitc796e5 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ettercap-0.7.5-0.fc17.20120906gitc796e5
Comment 8 Fedora Update System 2012-09-07 07:31:22 EDT
Package ettercap-0.7.5-0.fc17.20120906gitc796e5:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ettercap-0.7.5-0.fc17.20120906gitc796e5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13448/ettercap-0.7.5-0.fc17.20120906gitc796e5
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-09-10 09:41:12 EDT
ettercap-0.7.5-1.fc18.1.20120906gitc796e5 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ettercap-0.7.5-1.fc18.1.20120906gitc796e5
Comment 10 Fedora Update System 2012-09-10 09:45:49 EDT
ettercap-0.7.5-1.fc17.1.20120906gitc796e5 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ettercap-0.7.5-1.fc17.1.20120906gitc796e5
Comment 11 Fedora Update System 2012-09-17 20:01:44 EDT
ettercap-0.7.5-1.fc18.1.20120906gitc796e5 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-09-18 23:06:11 EDT
ettercap-0.7.5-1.fc17.1.20120906gitc796e5 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.