This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 855085 - [as] missing translation for the word "OPTIONS"
[as] missing translation for the word "OPTIONS"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
Entitlement Bugs
: Translation
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-09-06 12:03 EDT by John Sefler
Modified: 2013-01-07 23:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 23:03:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-09-06 12:03:30 EDT
Description of problem:
The word "options" is translated to বিকল্পসমূহ , yet "OPTIONS" has not been translated.

Version-Release number of selected component (if applicable):
[root@jsefler-59server ~]# rpm -q subscription-manager
subscription-manager-1.0.17-1.git.4.25d67b8.el5

How reproducible:


Steps to Reproduce:
[root@jsefler-59server ~]# msgunfmt /usr/share/locale/as/LC_MESSAGES/rhsm.mo | egrep -i "\[option.\]" -A1
msgid "%%prog %s [OPTIONS]"
msgstr "%%prog %s [OPTIONS]"

msgid "%%prog %s [OPTIONS] CERT_FILE"
msgstr "%%prog %s [OPTIONS] CERT_FILE"

--
msgid "%prog [OPTIONS]"
msgstr "%prog [OPTIONS]"

msgid "%prog [options]"
msgstr "%prog [বিকল্পসমূহ]"



Actual results:
above

Expected results:
Since there is a translation for msgid "%prog [options]", it seems to me that there should be a translation for the other "[OPTIONS]" too.
Comment 1 RHEL Product and Program Management 2012-09-06 12:17:05 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Bryan Kearney 2012-09-20 10:24:10 EDT
fixed in master in 735bf063ba740b7bbb8b5b09ccb2e0000ba9569b. Also fixed in zanata.
Comment 5 John Sefler 2012-10-18 15:44:13 EDT
Verifying Version...
[root@jsefler-rhel59 ~]# rpm -q subscription-manager
subscription-manager-1.0.23-1.el5


[root@jsefler-rhel59 ~]# msgunfmt /usr/share/locale/as/LC_MESSAGES/rhsm.mo | egrep -i "\[options\]" -A1
msgid "%%prog %s [OPTIONS]"
msgstr "%%prog %s [বিকল্পসমূহ]"
--
msgid "%%prog %s [OPTIONS] CERT_FILE"
msgstr "%%prog %s [বিকল্পসমূহ] CERT_FILE"
--
msgid "%prog [OPTIONS]"
msgstr "%prog [বিকল্পসমূহ]"
--
msgid "%prog [options]"
msgstr "%prog [বিকল্পসমূহ]"


VERIFIED: "[OPTIONS]" is translated in all msgids for LANG=as
Comment 7 errata-xmlrpc 2013-01-07 23:03:15 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.