Bug 855137 - Bodhi help-text suggests inadequate koji wait-repo command
Bodhi help-text suggests inadequate koji wait-repo command
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bodhi (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-06 14:58 EDT by Søren Sandmann Pedersen
Modified: 2016-09-19 22:43 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-01 04:48:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Søren Sandmann Pedersen 2012-09-06 14:58:00 EDT
When using buildroot-override, bodhi produces the following text:

    Your buildroot override has been successfully tagged. It may take up
    to 20 minutes for the buildroot to regenerate. You can wait for the
    new buildroot by running `koji wait-repo f18-build`

But "koji wait-repo f18-build" is not necessarily sufficient because a newRepo can be in progress at the time. If so, it will complete with the buildroot override. Instead the help text should say something like:

     koji wait-repo f18-build --build=[build]
Comment 1 Luke Macken 2012-11-13 14:58:31 EST
This issue has been fixed and will be hitting production shortly. Thanks for the report!

https://fedorahosted.org/bodhi/ticket/694
Comment 2 Fedora Update System 2012-11-13 16:57:17 EST
bodhi-0.9.3-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/bodhi-0.9.3-1.fc18
Comment 3 Fedora Update System 2012-11-13 20:31:06 EST
Package bodhi-0.9.3-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bodhi-0.9.3-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18150/bodhi-0.9.3-1.fc18
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-12-01 04:49:00 EST
bodhi-0.9.3-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.