Bug 855153 - Katello deployment allows for duplicate names in the same organization and environment.
Katello deployment allows for duplicate names in the same organization and en...
Status: CLOSED NOTABUG
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryan Kearney
SAM QE List
:
Depends On: 855152
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-06 15:54 EDT by Eric Sammons
Modified: 2012-09-13 10:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 855152
Environment:
Last Closed: 2012-09-13 10:04:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Sammons 2012-09-06 15:54:29 EDT
+++ This bug was initially created as a clone of Bug #855152 +++

Description of problem:
Katello master currently allows the same system to register using the same name multiple times, leaving previous copies of the name in the system list.

Version-Release number of selected component (if applicable):
katello-common-1.1.9-1.git.148.307e03b.fc16.noarch

Steps to Reproduce:
1. subscription-manager register --user admin --password admin --org ACME_Corporation --env DEV
2. subscription-manager clean
3. subscription-manager register --user admin --password admin --org ACME_Corporation --env DEV
  
Actual results:
When viewing the list of systems, via the ui or cli you will find multiple copies of the same system name.

headpin> system list --org ACME_Corporation
--------------------------------------------------------------------------------
                  Systems List For Org [ ACME_Corporation ]

 Name              Uuid                                   Ipv4 Address   Service Level  
--------------------------------------------------------------------------------
 localhost-12345   e18ae6a2-1857-4b0d-9d5c-21b81603ad09   x.x.x.x
 localhost-12345   c42390fe-d591-49d3-8285-2863fb741fad   x.x.x.x          

Expected results:
subscription-manager should have returned an error that the name is already taken and to use the --force option.

Additional info:
Comment 1 Tom McKay 2012-09-13 10:04:40 EDT
As discussed on IRC, this is not a bug but expected behaviour. There are valid use cases for a system to be registered, then cleaned, and another system registered. Systems with the same name is also a valid scenario.

Note You need to log in before you can comment on or make changes to this bug.