Bug 855157 - nfs-utils-1.2.3-15 can't unmount a filesystem that's root used a referral to another server.
nfs-utils-1.2.3-15 can't unmount a filesystem that's root used a referral to ...
Status: CLOSED DUPLICATE of bug 702273
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils (Show other bugs)
6.2
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Steve Dickson
Yin.JianHong
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-06 16:16 EDT by Weston Andros Adamson
Modified: 2013-08-14 14:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-14 14:10:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Weston Andros Adamson 2012-09-06 16:16:53 EDT
Description of problem:

If you mount server-a:/export, but that is referred to server-b:/export, you 
are unable to unmount that mountpoint!

# umount /mnt
/mnt was not found in /proc/mounts
/mnt was not found in /proc/mounts
# echo $?
32

The issue seems to be that /proc/mounts has the address of the referred server,
not the server originally mounted (or shown in output of "mount", "df").

I tracked this down to an issue in nfs-utils-1.2.3-15's utils/mount/nfsumount.c 
that has been fixed upstream by this commit (i think): dc08c702a6c7f824f317af561f491635ee898a71.

I say "i think" because I was unable to get the tag 'nfs-utils-1-2-3' to compile
on our RHEL 6.2 machines, but when I replaced /sbin/umount.nfs with one from 
the 'nfs-utils-1-2-4' tag everything worked!

Steve - Feel free to ping me if you need any more info (as always).

Version-Release number of selected component (if applicable):

1.2.3-15

How reproducible:

quite reproducible, but only with this version of nfs-utils.  nfs-utils from 
RHEL 6.1, 6.3 do not have this problem, nor does any recent nfs-utils.

Steps to Reproduce:
1. set up 2 nfs servers, one referring it's rootfs to the other
2. on the client, mount the first server
3. try to unmount
  
Actual results:

umount returns non zero, outputs errors, doesn't unmount

Expected results:

umount should work!

Additional info:
Comment 3 yanfu,wang 2013-01-09 21:51:16 EST
From Steve's discussion:
> https://bugzilla.redhat.com/show_bug.cgi?id=855157
Let push this one to 6.5...
Comment 8 Steve Dickson 2013-03-07 11:14:58 EST
commit dc08c702a6c7f824f317af561f491635ee898a71
Author: Chuck Lever <chuck.lever@oracle.com>
Date:   Wed Oct 13 13:55:10 2010 -0400

    umount.nfs: Distinguish between nfs4 and nfs mounts
Comment 10 Steve Dickson 2013-08-14 14:10:17 EDT

*** This bug has been marked as a duplicate of bug 702273 ***

Note You need to log in before you can comment on or make changes to this bug.