Bug 855171 - thinpool volume mirror conversion attempt fails
thinpool volume mirror conversion attempt fails
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.3
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Zdenek Kabelac
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-06 17:21 EDT by Corey Marthaler
Modified: 2013-02-21 03:13 EST (History)
9 users (show)

See Also:
Fixed In Version: lvm2-2.02.98-1.el6
Doc Type: Bug Fix
Doc Text:
Unsupported conversion of thin pool into a mirror had resulted into a aborting log error message. Explicit check which prohibits this conversion even before tool tries to do that has been added, so the error message gives clean explicit note about unsupported feature.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:13:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2012-09-06 17:21:03 EDT
Description of problem:
I'm not sure if this was ever supposed to be supported, but lvm allows a user to attempt this and it fails and requires user clean-up.

[root@taft-01 ~]# lvs -a -o +devices
  LV           VG            Attr     LSize  Pool Origin Data%  Devices
  POOL         snapper_thinp twi-a-tz  1.00g               0.00 POOL_tdata(0)
  [POOL_tdata] snapper_thinp Twi-aot-  1.00g                    /dev/sdc1(0)
  [POOL_tmeta] snapper_thinp ewi-aot-  4.00m                    /dev/sdb1(0)
  display_snap snapper_thinp Vwi-a-tz  1.00g POOL origin   0.00
  origin       snapper_thinp Vwi-a-tz  1.00g POOL          0.00

[root@taft-01 ~]# lvconvert -m 1 snapper_thinp/POOL
  Can't convert non-striped segment to mirrored.
  Aborting. Failed to add mirror segment. Remove new LV and retry.

[root@taft-01 ~]# lvs -a -o +devices
  LV              VG            Attr     LSize  Pool Origin Data%  Devices
  POOL            snapper_thinp twi-a-tz  1.00g               0.00 POOL_tdata(0)
  [POOL_mimage_0] snapper_thinp -wi-----  1.00g                    /dev/sdb1(1)
  [POOL_tdata]    snapper_thinp Twi-aot-  1.00g                    /dev/sdc1(0)
  [POOL_tmeta]    snapper_thinp ewi-aot-  4.00m                    /dev/sdb1(0)
  display_snap    snapper_thinp Vwi-a-tz  1.00g POOL origin   0.00
  origin          snapper_thinp Vwi-a-tz  1.00g POOL          0.00


Version-Release number of selected component (if applicable):
2.6.32-279.el6.x86_64

lvm2-2.02.95-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
lvm2-libs-2.02.95-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
lvm2-cluster-2.02.95-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
udev-147-2.41.el6    BUILT: Thu Mar  1 13:01:08 CST 2012
device-mapper-1.02.74-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
device-mapper-libs-1.02.74-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
device-mapper-event-1.02.74-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
device-mapper-event-libs-1.02.74-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
cmirror-2.02.95-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
Comment 1 Corey Marthaler 2012-09-06 17:39:07 EDT
Looks like no mirroring should be attempted with thin pools, and that the check only works w/ raid1 mirrors?

[root@taft-01 ~]# lvconvert --type raid1 -m 1 snapper_thinp/POOL
  '--mirrors/-m' is not compatible with thin-pool
Comment 2 Zdenek Kabelac 2012-10-08 08:22:02 EDT
Prohibited as unsupported yet:

https://www.redhat.com/archives/lvm-devel/2012-October/msg00025.html
Comment 4 Corey Marthaler 2013-01-04 17:26:48 EST
Fix verified in the latest rpms.

2.6.32-348.el6.x86_64
lvm2-2.02.98-6.el6    BUILT: Thu Dec 20 07:00:04 CST 2012
lvm2-libs-2.02.98-6.el6    BUILT: Thu Dec 20 07:00:04 CST 2012
lvm2-cluster-2.02.98-6.el6    BUILT: Thu Dec 20 07:00:04 CST 2012
udev-147-2.43.el6    BUILT: Thu Oct 11 05:59:38 CDT 2012
device-mapper-1.02.77-6.el6    BUILT: Thu Dec 20 07:00:04 CST 2012
device-mapper-libs-1.02.77-6.el6    BUILT: Thu Dec 20 07:00:04 CST 2012
device-mapper-event-1.02.77-6.el6    BUILT: Thu Dec 20 07:00:04 CST 2012
device-mapper-event-libs-1.02.77-6.el6    BUILT: Thu Dec 20 07:00:04 CST 2012
cmirror-2.02.98-6.el6    BUILT: Thu Dec 20 07:00:04 CST 2012


SCENARIO - [pool_to_conversion]
Attempt to convert a thinp pool device to mirror, raid1, raid4, raid5, and raid6
Making origin volume
Creating thinpool and corresponding thin virtual volumes (one to be used as an origin)
lvcreate --thinpool POOL -L 4G snapper_thinp
lvcreate --virtualsize 1G --thinpool snapper_thinp/POOL -n origin
lvcreate --virtualsize 1G --thinpool snapper_thinp/POOL -n other1
lvcreate --virtualsize 1G --thinpool snapper_thinp/POOL -n other2
lvcreate --virtualsize 1G --thinpool snapper_thinp/POOL -n other3
lvcreate --virtualsize 1G --thinpool snapper_thinp/POOL -n other4
lvcreate --virtualsize 1G --thinpool snapper_thinp/POOL -n other5
Making snapshot of origin volume
lvcreate -s /dev/snapper_thinp/origin -n pool_convert

Attempt mirror conversion of pool device...
lvconvert -m 1 snapper_thinp/POOL
  Converting segment type for snapper_thinp/POOL to mirror is not yet supported.

Attempt raid1 conversion of pool device...
lvconvert --type raid1 -m 1 snapper_thinp/POOL
  '--mirrors/-m' is not compatible with thin-pool

Attempt raid4 conversion of pool device...
lvconvert --type raid4 -i 2 snapper_thinp/POOL
  Converting the segment type for snapper_thinp/POOL from thin-pool to raid4 is not yet supported.

Attempt raid5 conversion of pool device...
lvconvert --type raid5 -i 2 snapper_thinp/POOL
  Converting the segment type for snapper_thinp/POOL from thin-pool to raid5 is not yet supported.

Attempt raid6 conversion of pool device...
lvconvert --type raid6 -i 3 snapper_thinp/POOL
  Converting the segment type for snapper_thinp/POOL from thin-pool to raid6 is not yet supported.
Comment 5 errata-xmlrpc 2013-02-21 03:13:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0501.html

Note You need to log in before you can comment on or make changes to this bug.