This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 855219 - [abrt] ibus-1.4.99.20120712-1.fc17: Process /usr/libexec/ibus-ui-gtk3 was killed by signal 11 (SIGSEGV)
[abrt] ibus-1.4.99.20120712-1.fc17: Process /usr/libexec/ibus-ui-gtk3 was kil...
Status: CLOSED DUPLICATE of bug 804743
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:5e7f9a36fa819b5e7cdc28e843e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-06 22:38 EDT by John L. Ries
Modified: 2012-10-01 09:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-01 09:17:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: open_fds (451 bytes, text/plain)
2012-09-06 22:38 EDT, John L. Ries
no flags Details
File: dso_list (5.91 KB, text/plain)
2012-09-06 22:38 EDT, John L. Ries
no flags Details
File: environ (908 bytes, text/plain)
2012-09-06 22:38 EDT, John L. Ries
no flags Details
File: cgroup (128 bytes, text/plain)
2012-09-06 22:38 EDT, John L. Ries
no flags Details
File: var_log_messages (331 bytes, text/plain)
2012-09-06 22:38 EDT, John L. Ries
no flags Details
File: maps (32.54 KB, text/plain)
2012-09-06 22:38 EDT, John L. Ries
no flags Details
File: limits (1.29 KB, text/plain)
2012-09-06 22:38 EDT, John L. Ries
no flags Details
File: backtrace (19.44 KB, text/plain)
2012-09-06 22:38 EDT, John L. Ries
no flags Details
File: core_backtrace (949 bytes, text/plain)
2012-09-06 22:38 EDT, John L. Ries
no flags Details

  None (edit)
Description John L. Ries 2012-09-06 22:38:42 EDT
Version-Release number of selected component:
ibus-1.4.99.20120712-1.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/libexec/ibus-ui-gtk3
crash_function: _gdk_device_xi2_reset_scroll_valuators
kernel:         3.5.2-3.fc17.x86_64

truncated backtrace:
:Thread no. 1 (9 frames)
: #0 _gdk_device_xi2_reset_scroll_valuators at gdkdevice-xi2.c
: #1 gdk_x11_device_manager_xi2_translate_event at gdkdevicemanager-xi2.c
: #3 _gdk_x11_event_translator_translate at gdkeventtranslator.c
: #4 gdk_event_source_translate_event at gdkeventsource.c
: #5 _gdk_x11_display_queue_events at gdkeventsource.c
: #6 gdk_display_get_event at gdkdisplay.c
: #12 gtk_main at gtkmain.c
: #13 application_run at application.c
: #14 application_main at application.c
Comment 1 John L. Ries 2012-09-06 22:38:44 EDT
Created attachment 610578 [details]
File: open_fds
Comment 2 John L. Ries 2012-09-06 22:38:45 EDT
Created attachment 610579 [details]
File: dso_list
Comment 3 John L. Ries 2012-09-06 22:38:47 EDT
Created attachment 610580 [details]
File: environ
Comment 4 John L. Ries 2012-09-06 22:38:48 EDT
Created attachment 610581 [details]
File: cgroup
Comment 5 John L. Ries 2012-09-06 22:38:50 EDT
Created attachment 610582 [details]
File: var_log_messages
Comment 6 John L. Ries 2012-09-06 22:38:51 EDT
Created attachment 610583 [details]
File: maps
Comment 7 John L. Ries 2012-09-06 22:38:52 EDT
Created attachment 610584 [details]
File: limits
Comment 8 John L. Ries 2012-09-06 22:38:54 EDT
Created attachment 610585 [details]
File: backtrace
Comment 9 John L. Ries 2012-09-06 22:38:55 EDT
Created attachment 610586 [details]
File: core_backtrace
Comment 10 fujiwara 2012-09-07 04:04:19 EDT
(In reply to comment #8)
> Created attachment 610585 [details]
> File: backtrace

#0  _gdk_device_xi2_reset_scroll_valuators (device=device@entry=0x0) at gdkdevice-xi2.c:853
        i = 0
#1  0x0000003345e3ffd3 in gdk_x11_device_manager_xi2_translate_event (xevent=0x7fff16da2880, event=0x16a1c50, display=0x14c9010 [GdkX11Display], translator=0x14a5a30) at gdkdevicemanager-xi2.c:1551
        xev = 0x1869e10
        device = <optimized out>
        source_device = 0x0
        return_val = <optimized out>
        window = <optimized out>
        ev = 0x1869e10
#2  gdk_x11_device_manager_xi2_translate_event (translator=0x14a5a30, display=0x14c9010 [GdkX11Display], event=0x16a1c50, xevent=0x7fff16da2880) at gdkdevicemanager-xi2.c:1101
        device_manager = 0x14a5a30 [GdkX11DeviceManagerXI2]
        cookie = 0x7fff16da2880


I cannot reproduce the device == 0 in _gdk_device_xi2_reset_scroll_valuators().
Are still able to reproduce your problem?
Comment 11 Marek Kašík 2012-10-01 09:17:54 EDT

*** This bug has been marked as a duplicate of bug 804743 ***

Note You need to log in before you can comment on or make changes to this bug.