Bug 855220 - Kernel 3.5.3-1.fc17.x86_64 fails normal boot on an Acer Aspire One 722
Kernel 3.5.3-1.fc17.x86_64 fails normal boot on an Acer Aspire One 722
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-06 22:46 EDT by Jim Bray
Modified: 2012-12-20 10:59 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:59:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Bray 2012-09-06 22:46:19 EDT
Description of problem:

  I'm running F17 (current to updates-testing, other than the kernel) on an Acer Aspire one 722 (AMD C60, graphics per lspci:
00:01.0 VGA compatible controller: ATI Technologies Inc Device 9807
). I've got an encrypted lvm setup. The boot was fine up to the point at which it tried to switch to a graphics mode to get the key to the filesystem. First the screen filled with vertical alternating black and white bars, then went black.

  I repeated, then erased the kernel. I did not gather much info as I was not planning to report, but it occurred to me that this might occur with the 3.6 kernel in F18, and if so would probably be an alpha-blocker bug, so should be reported. So I did not try booting to single user or other obvious things.

  I can investigate further or test a proposed F18 kernel if desired.

Version-Release number of selected component (if applicable):

3.5.3


How reproducible:

Try to boot to GUI.

  
Actual results:

Black screen


Expected results:

Running system
Comment 1 Jim Bray 2012-09-09 10:25:40 EDT
This kernel is now in FC17 updates.

It can be booted by editing the boot sequence to boot to single-user.

On normal (multi-user) boot, it reaches the point at which it wants the password to decrypt the filesystem, at which point it switches to graphics, displays vertical bars for about 5 seconds, and then acts hung, but can be rebooted via alt-sysrq commands.

If booted with "s" appended to the linux grub2 command-line, it correctly enters some graphics mode, requests the password, and reaches single-user, and then finishes booting normally on exit from SU.
Comment 2 Jim Bray 2012-09-09 11:01:35 EDT
3.6.0-0.rc4.git2.1.fc18.x86_64 boots normally. It is unusable due to X consuming all CPU, but that is a separate issue, hopefully just an incompatibility.
Comment 3 Josh Boyer 2012-10-08 10:59:41 EDT
F17 should get a 3.6 update this week sometime.  We'll mark this as POST for now and assume it's fixed with that update.  If you test it and it fails still, please comment here.
Comment 4 Fedora Update System 2012-10-10 11:37:58 EDT
kernel-3.6.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.6.1-1.fc17
Comment 5 Jim Bray 2012-10-10 12:01:59 EDT
Sorry, can't test it. The Fedora 18 Alpha installer wiped my disk without warning, Win7 and Fedora gone, can't recover anything with testdisk. Switched to Linux Mint LMDE, doubt I will ever try Fedora again.
Comment 6 Artyom Kunyov 2012-10-10 12:22:17 EDT
(In reply to comment #5)
> Sorry, can't test it. The Fedora 18 Alpha installer wiped my disk without
> warning, Win7 and Fedora gone, can't recover anything with testdisk.
> Switched to Linux Mint LMDE, doubt I will ever try Fedora again.

Well, I'd be more careful if I decided to try Alpha version of a distribution like Fedora.
Comment 7 Jim Bray 2012-10-10 12:32:04 EDT
Good point. I'm sticking with Alphas of other distributions from now on.
Comment 8 Artyom Kunyov 2012-10-10 12:41:26 EDT
(In reply to comment #7)
> Good point. I'm sticking with Alphas of other distributions from now on.

If you like bleeding edge, you should try Arch. It's a bit more difficult to install, but at least it's more stable than Alphas of traditional release model distros.
Comment 9 Josh Boyer 2012-10-10 12:43:59 EDT
(In reply to comment #5)
> Sorry, can't test it. The Fedora 18 Alpha installer wiped my disk without
> warning, Win7 and Fedora gone, can't recover anything with testdisk.
> Switched to Linux Mint LMDE, doubt I will ever try Fedora again.

Unfortunate.  Did you read the release notes before you tried the Alpha?  This issue was pointed out there.
Comment 10 Jim Bray 2012-10-10 12:56:38 EDT
Apparently RedHat/Fedora has developed a Microsoft-like attitude that wiping data is to be expected.

I didn't read the release notes. If I was to buy a car, I wouldn't read the owner's manual looking for warnings that the car was prone to explosion. In my fairly wide and long experience,  the rest of the linux world doesn't seem to think releasing disk-eating ISO images is quite the thing.

 I'll keep Arch in mind.I've had good luck with Debian/unstable for most of the last 15 years ir so, tried quite a few others, always bleeding-edge. What is so disturbing in this case is that it was known the installer would trash the disk without warning, and this, by an 8 to 5 vote, wasn't considered a big problem. See bug beliw for details.

https://bugzilla.redhat.com/show_bug.cgi?id=855976

Writing on a phone, can't fix the typos, so s/i/o
Comment 11 Josh Boyer 2012-10-10 13:04:07 EDT
We thank you for testing nonetheless.  Good luck in your travels elsewhere.
Comment 12 Jim Bray 2012-10-10 13:45:30 EDT
Thanks. Good luck with Fedora. I was favorably impressed with 16 and 17. A lot of things "just worked" which require tinkering in Debian.
Comment 13 Fedora Update System 2012-10-10 20:59:11 EDT
Package kernel-3.6.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.6.1-1.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15855/kernel-3.6.1-1.fc17
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2012-12-20 10:59:36 EST
kernel-3.6.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.