Bug 855236 - SLOF package builds wrong version of SLOF
SLOF package builds wrong version of SLOF
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: SLOF (Show other bugs)
18
All Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-07 00:35 EDT by David Gibson
Modified: 2012-09-27 01:09 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-14 05:42:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Gibson 2012-09-07 00:35:51 EDT
Description of problem:

AFAICT the SLOF package exists only to provide a SLOF image for use with qemu (specifically for qemu-system-ppc64 -M pseries).

However, the %build section of the spec file does "make js22x" instead of "make qemu" so it makes a SLOF suitable for JS22 blades, not for the qemu virtual pseries machine.  The qemu machine will crash immediately, since the JS22 image accesses registes which don't exist on the CPUs used by the pseries machine.
Comment 1 Paolo Bonzini 2012-09-14 05:42:10 EDT
Fixed in commit 6bdc3bd35defb43522faee3284344bc322d7ce8c.
Comment 2 Fedora Update System 2012-09-14 05:56:18 EDT
SLOF-0-0.1.git20120731.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/SLOF-0-0.1.git20120731.fc16
Comment 3 Fedora Update System 2012-09-14 05:57:05 EDT
SLOF-0-0.1.git20120731.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/SLOF-0-0.1.git20120731.fc17
Comment 4 David Gibson 2012-09-16 21:07:22 EDT
Looks good, thanks.
Comment 5 Fedora Update System 2012-09-19 07:32:18 EDT
SLOF-0-0.1.git20120731.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/SLOF-0-0.1.git20120731.fc18
Comment 6 Fedora Update System 2012-09-27 01:09:41 EDT
SLOF-0-0.1.git20120731.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.