Red Hat Bugzilla – Bug 855267
[RFE] in "product" CLI commands add new option "product_id"
Last modified: 2014-09-18 12:42:17 EDT
Description of problem:
As the name of product is not unique anymore, it does not make sense to do operations with product by it's name in CLI.
It needs new option "product_id" added instead on "name" in product CLI.
Like the "product update --name --org --description" it should be
"product update --product_id --org --description".
And the same for all product commands.
this will most likely be addressed in the following bug that makes product name unique:
This is a blocker since the CLI and API will no longer function with non-unique product names.
This issue appears to affect the following CLI commands which use product name:
product: update, delete, synchronize, status, cancel_sync, add_filter, list_filters, remove_filter, promote, set_plan, remove_plan
repo: create, discover, list
In order to address this bugzilla, we are adding the ability for the user to specify product name, label or id in the various commands where products are currently specified. Since the same name may be used for multiple products, users may want to use product id always; however, names remain supported for backward compatability.
That said, if product name or label is provided and multiple products exist with that name/label, the user will receive an error message similar to:
"More than 1 product found with the name or label provided, recommend
using product id. The product id may be retrieved using the 'product
Prior to the changes, the CLI would always use the 'first' product that matched, which can result in unexpected behaviors.
This bugzilla affects several commands, such as the following:
- product update
- product add_filter
- product list_filters
- product remove_filter
- product set_plan
- product remove_plan
- product synchronize
- product status
- product cancel_sync
- product promote
- product delete
- changeset update (includes --add_product, --remove_product and --from_product)
- errata list
- errata info
- package list
- package info
- repo create
- repo discover
- repo list
- repo status
- repo info
- repo update
- repo synchronize
- repo cancel_sync
- repo enable
- repo delete
- repo list_filters
- repo add_filter
- repo remove_filter
katello github pull request:
Verified on revision:
product_id parameter is added for all mentioned commands and it works correctly.
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory, and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
getting rid of 6.0.0 version since that doesn't exist