Bug 855301 - spice-xpi doesn't build on on non x86
Summary: spice-xpi doesn't build on on non x86
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: spice-xpi
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Hatina
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 613529
Blocks: ARMTracker
TreeView+ depends on / blocked
 
Reported: 2012-09-07 09:37 UTC by Peter Robinson
Modified: 2016-06-01 01:31 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-01-09 09:27:53 UTC


Attachments (Terms of Use)
Remove check for x86 arch so it will allow building on any arch (679 bytes, patch)
2012-09-07 09:37 UTC, Peter Robinson
no flags Details | Diff
apply patches to spec (1.51 KB, patch)
2012-09-07 09:40 UTC, Peter Robinson
no flags Details | Diff

Description Peter Robinson 2012-09-07 09:37:43 UTC
Created attachment 610672 [details]
Remove check for x86 arch so it will allow building on any arch

ARM is a perfect client for a spice thin client and spice-gtk is currently supported on ARM. For some reason spice-xpi is not even though I can't see any reason why it shouldn't work.

The following patches (one to the spec and one to configure.ac) allows it to build. I'll be testing further to see if it works.

Comment 1 Peter Robinson 2012-09-07 09:40:55 UTC
Created attachment 610674 [details]
apply patches to spec

Comment 2 Dan Horák 2012-09-07 09:48:40 UTC
I think similar cpu check was removed from spice-gtk some time ago.

Comment 3 Peter Robinson 2012-09-07 10:19:46 UTC
(In reply to comment #2)
> I think similar cpu check was removed from spice-gtk some time ago.

Yes, but I just discovered it depends on spice-client too.

Comment 4 Peter Robinson 2012-09-07 10:20:06 UTC
Scratch build on ARM http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1123594

Comment 5 Peter Robinson 2012-09-07 13:09:25 UTC
The above works with the patches to spice posted on the dependant bug on an ARMv7 device. Arch might be better set to 

ExclusiveArch:  i686 x86_64 armv6l armv7l armv7hl

for the moment.

Comment 6 Peter Hatina 2012-09-11 11:38:55 UTC
Looks good, pushed to f18 git.

Comment 7 DaGeek 2012-09-11 11:59:25 UTC
can this also be tested/built on Fedora17 ?
So that it can become available in the update repos before Fedora18 GA ?

Comment 8 Peter Hatina 2013-01-09 09:27:53 UTC
There is a package available for f17, spice-xpi-2.8-2.fc17


Note You need to log in before you can comment on or make changes to this bug.