Bug 855344 - please split out/disable package installation bits
please split out/disable package installation bits
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: realmd (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stef Walter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 854355 860760
  Show dependency treegraph
 
Reported: 2012-09-07 09:22 EDT by Bill Nottingham
Modified: 2014-03-16 23:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:04:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 55017 None None None 2012-09-17 09:28:24 EDT

  None (edit)
Description Bill Nottingham 2012-09-07 09:22:03 EDT
Description of problem:

Right now we're dragging in way too many dependencies from realmd being in the 'standard' install group.

Version-Release number of selected component (if applicable):

0.6-1.fc18

How reproducible:

100%

Steps to Reproduce:
1. yum groupinstall core standard
  
Actual results:

Oh look, I have PackageKit and gtk2 and preupgrade and cairo and mesa installed.

Expected results:

Not That.

Additional info:
Comment 1 Stef Walter 2012-09-08 05:35:44 EDT
Didn't packagekit-glib2 dragged in GTK2 in the fedora packages. That seems broken. But in any case, I was planning to use PackageKit via raw DBus anyway. So this is definitely doable.
Comment 2 Bill Nottingham 2012-09-10 13:47:35 EDT
I believe the dep tree is realmd -> PackageKit-glib -> PackageKit -> gtk2/cairo/etc
Comment 3 Richard Hughes 2012-09-17 10:39:46 EDT
(In reply to comment #1)
> Didn't packagekit-glib2 dragged in GTK2 in the fedora packages. That seems
> broken. But in any case, I was planning to use PackageKit via raw DBus
> anyway. So this is definitely doable.

I'd rather you used the glib library to be honest. I can fix either the PackageKit-glib -> PackageKit or PackageKit -> gtk2 problems, but not using the library is probably the wrong thing to do.
Comment 4 Stef Walter 2012-09-17 11:33:34 EDT
Yeah, it's a tough decision.

From the little I've seen, it looks like the packagekit-glib2 library does stuff not applicable to using package-kit from a system service. On the other hand there's a lot of constants and assumed knowledge in the DBus interface, which makes the DBus interface look like an implementation detail of PackageKit.

Lastly, we end up running several distro dependent system commands from realmd. So if PackageKit is a poor fit for being called from another system service. All we need to do is install a list of packages. So perhaps we could call the CLI distro dependent commands ourselves.
Comment 5 Stef Walter 2012-09-18 12:20:13 EDT
Richard has changed the packagekit-glib library dependencies so that PackageKit and gtk are no longer pulled in:

http://pkgs.fedoraproject.org/cgit/PackageKit.git/commit/?id=38fbad9316cf374d367f78fb66ad64773a86cfaf

Bill, Does that address the concerns you had when filing this bug?

Obviously the changes would need to be back-ported to the f18 branch.
Comment 6 Bill Nottingham 2012-09-25 00:12:22 EDT
It hits the large parts of the dependency chain, yes.
Comment 7 Stef Walter 2012-09-25 01:35:31 EDT
Richard, when are you going to backport the dependency changes to Fedora 18. This is pretty bad for realmd usage right now on Fedora 18 alphas.
Comment 8 Fedora Update System 2012-09-26 04:11:17 EDT
PackageKit-0.8.3-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/PackageKit-0.8.3-3.fc18
Comment 9 Fedora Update System 2012-09-26 17:20:13 EDT
Package PackageKit-0.8.3-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing PackageKit-0.8.3-3.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14821/PackageKit-0.8.3-3.fc18
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-10-01 09:24:15 EDT
PackageKit-0.8.4-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/PackageKit-0.8.4-1.fc18
Comment 11 Fedora Update System 2012-10-04 07:11:30 EDT
PackageKit-0.8.4-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/PackageKit-0.8.4-3.fc18
Comment 12 Fedora Update System 2012-12-20 11:04:43 EST
PackageKit-0.8.4-3.fc18, apper-0.8.0-0.7.20121002git.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.